summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:50:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:06 -0400
commit802a3b7ba33562925dbd02ae742b6ea4dfd36910 (patch)
tree7963ab92616a1bf98238ad5e26bef04a4d79147d /gnu/packages/check.scm
parentfa2c1689c8972a1cdd111bcbc114c25fbf447904 (diff)
gnu: python-pytest-7.1: Deprecate package.
The source was adjusted using the following command: $ git grep -rl python-pytest-7.1 | xargs sed -i 's/python-pytest-7.1/python-pytest/g' * gnu/packages/check.scm (python-pytest-7.1): Delete variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm26
1 files changed, 2 insertions, 24 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 90a6fba2b9..f388eb82a7 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1305,30 +1305,8 @@ and many external plugins.")
(define-deprecated python-pytest-6 python-pytest)
(export python-pytest-6)
-;; Astropy started using hard dependencies for Pytest 7+, which might
-;; happen for some other projects. It could be set as default in staging.
-(define-public python-pytest-7.1
- (package
- (inherit python-pytest)
- (version "7.1.3")
- (name "python-pytest")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest" version))
- (sha256
- (base32
- "0f8c31v5r2kgjixvy267n0nhc4xsy65g3n9lz1i1377z5pn5ydjg"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-pytest)
- ((#:phases phases #~%standard-phases)
- #~(modify-phases #$phases
- (add-before 'build 'pretend-version
- (lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))
- (propagated-inputs
- (modify-inputs (package-propagated-inputs python-pytest)
- (replace "python-toml" python-tomli)))))
+(define-deprecated python-pytest-7 python-pytest)
+(export python-pytest-7)
(define-public python-pytest-bootstrap
(package