summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-01 10:48:35 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-02-26 01:00:00 +0100
commit997b93cc4a6deff54ebd854a716cca94095114bf (patch)
treef6b816bf91a2a5955bf61cdc7e779460467bd1ad /gnu/packages/check.scm
parent89e5f3f3847b3bfd507ea9f0874a73f99a53cbf9 (diff)
gnu: go-github-com-robfig-cron-1.2: Move to (gnu packages golang).
Because (gnu packages golang) and (gnu packages check) use each other, this avoids an undefined symbol due to a module dependency cycle. * gnu/packages/check.scm (go-github-com-robfig-cron-1.2): Move to... * gnu/packages/golang.scm (go-github-com-robfig-cron-1.2): ...here. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4e907afeb6..44860e3018 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1029,24 +1029,6 @@ C++ but is used in C and C++ projects and frequently used in embedded systems
but it works for any C/C++ project.")
(license license:bsd-3)))
-;; Required by actionlint. The version of `go-github-com-robfig-cron'
-;; packaged in Guix is newer and changed some error messages, causing
-;; unit tests in actionlint to fail.
-(define-public go-github-com-robfig-cron-1.2
- (package
- (inherit go-github-com-robfig-cron)
- (name "go-github-com-robfig-cron")
- (version "1.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/robfig/cron")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0nv31m3940d9kf38lw2zs4hpj435bdi9mmim098rb3n4l07qrvva"))))))
-
(define-public actionlint
(package
(name "actionlint")