summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-11 16:13:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-11 16:13:56 +0300
commit02fbd89f2b69ebb1793261026c4471280048335f (patch)
treed4b45659d0e591d474d277c559b6e3a6c0be95d1 /gnu/packages/check.scm
parent1f18f18e85da6652a078f24220d4f4b4957801a0 (diff)
gnu: python-fixtures: Fix building.
* gnu/packages/check.scm (python-fixtures-bootstrap)[source]: Add patch. * gnu/packages/patches/python-fixtures-remove-monkeypatch-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 9cd53725ba..eb20d0fd54 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1578,12 +1578,14 @@ protocol.")))
(package
(name "python-fixtures-bootstrap")
(version "3.0.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "fixtures" version))
- (sha256
- (base32
- "1vxj29bzz3rd4pcy51d05wng9q9dh4jq6wx92yklsm7i6h1ddw7w"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fixtures" version))
+ (sha256
+ (base32
+ "1vxj29bzz3rd4pcy51d05wng9q9dh4jq6wx92yklsm7i6h1ddw7w"))
+ (patches (search-patches "python-fixtures-remove-monkeypatch-test.patch"))))
(build-system python-build-system)
(arguments
`(#:tests? #f