summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-08-01 23:23:32 +0200
committerMarius Bakke <marius@gnu.org>2021-08-01 23:23:32 +0200
commitd2e102d4e4fc5288d93e1100e86b35938a9ac162 (patch)
treeb5ec688c954f7736c17371d9c76ff30509e8e6e8 /gnu/packages/check.scm
parentb2a5a180cfa56e55bc8078d606a971e34e326967 (diff)
parent536bec1ce5b3d68a6773f31e3788c63e8905ce98 (diff)
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index fbdc46cd4a..fd35eed041 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2015, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2017, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
@@ -733,6 +733,33 @@ generation.")
(base32
"0270msj6n7mggh4xqqjp54kswbl7mkcc8px1p5dqdpmw5ngh9fzk"))))))
+(define-public googlebenchmark
+ (package
+ (name "googlebenchmark")
+ (version "1.5.3")
+ (home-page "https://github.com/google/benchmark")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "google-benchmark" version))
+ (sha256
+ (base32
+ "1hls0aqqj5cfldn9jfpvzjhpxkhrydrz9crp477rwllwjsybdxw7"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
+ (string-append
+ "-DGOOGLETEST_PATH="
+ (assoc-ref %build-inputs "googletest")))))
+ (inputs
+ `(("googletest" ,(package-source googletest))))
+ (synopsis "C++ library to support the benchmarking of functions")
+ (description
+ "The googlebenchmark C++ library support the benchmarking of functions,
+similar to unit tests.")
+ (license license:asl2.0)))
+
(define-public cpputest
(package
(name "cpputest")