summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 15:41:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:48 +0200
commitc9efffe3d0bfe9208dc119d9a8a0e87f8ee3b838 (patch)
tree75e7d5e4516ca49ef9efa8a0a641a5937d3577b1 /gnu/packages/chez.scm
parente6fc11ae07274582031283f2f63285d1374b583f (diff)
gnu: chez-web: Fix build.
* gnu/packages/chez.scm (chez-web)[native-inputs]: Add TEXLIVE-CHARTER, TEXLIVE-CWEB, remove TEXLIVE-EPSF. [arguments]<#:phases>: Add phases to fix ".tex" issues.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 99c8dcac3a..3467783dd3 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -1008,12 +1008,11 @@ create compilers, making them easier to understand and maintain.")
(native-inputs
(list (chez-scheme-for-system)
ghostscript
- ;; FIXME: This package fails to build with the error:
- ;; mktexpk: don't know how to create bitmap font for bchr8r
- ;; Replacing the following with `texlive` fixes it.
- ;; What is missing?
(texlive-updmap.cfg
- (list texlive-context texlive-epsf texlive-metapost))))
+ (list texlive-charter
+ texlive-context
+ texlive-cweb
+ texlive-metapost))))
(arguments
(list
#:make-flags
@@ -1023,9 +1022,18 @@ create compilers, making them easier to understand and maintain.")
;; lib/chez-scheme/chezweb ???
(string-append "LIBDIR=" #$output "/lib/chezweb")
(string-append "TEXDIR=" #$output "/share/texmf-local"))
- #:tests? #f ; no tests
+ #:tests? #f ; no tests
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tex-input
+ (lambda _
+ ;; Fix "I can't find file `supp-pdf'." error.
+ (substitute* "chezweb.w"
+ (("supp-pdf") "supp-pdf.mkii"))
+ ;; Recent cweb packages do not include "\acrofalse". Remove
+ ;; it.
+ (substitute* "doc/cwebman.tex"
+ (("\\acrofalse.*") ""))))
;; This package has a custom "bootstrap" script that
;; is meant to be run from the Makefile.
(delete 'bootstrap)