summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-11-17 19:45:30 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-11-20 02:22:18 +0100
commitfca5e1a507b20939387fada4a7bcbae7bc3bbbe7 (patch)
treef23f7fdd7972244eb50260efda1fec2e9eda4f4f /gnu/packages/chez.scm
parentbd0ff2d39bc7d3b497d74c3431ef77a1cf2515c4 (diff)
gnu: racket: Update to 8.7.
Also, update 'chez-scheme-for-racket' to 9.5.9.8. Note that racket-backport-8.6-cross-install.patch, racket-backport-8.6-docindex-write.patch, and racket-backport-8.6-hurd.patch were missing from dist_patch_DATA. * gnu/packages/patches/racket-backport-8.6-cross-install.patch, gnu/packages/patches/racket-backport-8.6-docindex-write.patch, gnu/packages/patches/racket-backport-8.6-hurd.patch, gnu/packages/patches/racket-backport-8.6-zuo.patch: Remove patches. * gnu/packages/patches/racket-backport-8.7-pkg-strip.patch: New patch. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/racket.scm (%racket-origin)[patches]: Likewise. (%racket-version): Update to 8.7. (racket)[inputs]: Add 'scheme-doc' source package from '%racket-origin'. (racket)[inputs]<compatibility, db, deinprogramm, draw, drracket> <eopl, errortrace, gui, htdp, mzscheme, parser-tools, pict, plai, plot> <r6rs, redex, scribble, slideshow, snip, typed-racket, srfi> <string-constants>: Update checksums. * gnu/packages/chez.scm (chez-scheme-for-racket): Update to 9.5.9.8. [arguments]: Enable tests. [description]: Update. (chez-scheme-for-racket-bootstrap-bootfiles)[arguments]: Update path to 'rktboot'. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 5d152b3db5..7025a71b94 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -466,8 +466,8 @@ and 32-bit PowerPC architectures.")
(package
(inherit chez-scheme)
(name "chez-scheme-for-racket")
- (version "9.5.9.2")
- ;; The version should match `(scheme-fork-version-number)`.
+ (version "9.5.9.8")
+ ;; The version should match `scheme-version`.
;; See racket/src/ChezScheme/s/cmacros.ss c. line 360.
;; It will always be different than the upstream version!
;; When updating, remember to also update %racket-version in racket.scm.
@@ -492,12 +492,6 @@ and 32-bit PowerPC architectures.")
(substitute-keyword-arguments (package-arguments chez-scheme)
((#:out-of-source? _ #f)
#t)
- ((#:tests? _ #t)
- ;; FIXME: There have been some flaky test failures. Some have been
- ;; fixed upstream post-release but have proven non-trivial to
- ;; backport; at least one issue remains. Re-enable tests once
- ;; https://github.com/racket/racket/issues/4359 is fixed.
- #f)
((#:configure-flags cfg-flags #~'())
#~`("--disable-x11"
"--threads" ;; ok to potentially duplicate
@@ -590,7 +584,7 @@ supported by upstream Chez Scheme.
Main additions to Chez Scheme in the Racket variant:
@itemize @bullet
@item
-AArch64 code generation
+AArch64 and RV64G (RISC-V) code generation
@item
Portable bytecode (@code{pb}) mode, which is mainly useful for bootstrapping a
build on any platform, but can also be used on platforms without native-code
@@ -603,7 +597,7 @@ Faster multiplication and division for large exact numbers
@item
Type reconstruction during optimization (especially for safe code)
@item
-Continuation attachments
+Continuation marks
@item
Parallel garbage collection, in-place garbage collection for old-generation
objects (instead of always copying), and reachability-based memory
@@ -611,6 +605,8 @@ accounting
@item
Ordered finalization, immobile (but collectable) objects, weak/ephemeron
generic hash tables, and reference bytevectors
+@item
+Easier bootstrapping via old versions of Chez Scheme
@end itemize")
(license asl2.0)))
@@ -695,7 +691,7 @@ source.")))
#~(invoke
(search-input-file (or native-inputs inputs)
"/opt/racket-vm/bin/racket")
- "rktboot/main.rkt"
+ "../rktboot/main.rkt"
#$@(if (racket-cs-native-supported-system?)
#~()
(let ((m (nix-system->pbarch-machine-type)))