summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-08-27 14:55:48 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:11 +0200
commit9647296ce618fbc79026534c3fafb1a538612697 (patch)
tree7cf87b4b1cbadfec311ba4c459e088d92bec6d2b /gnu/packages/chez.scm
parent07a8440f502a1e864258417af37c25ca33e24dde (diff)
gnu: racket: Update to 8.6.
Also, update 'chez-scheme-for-racket' to 9.5.9.2. * gnu/packages/patches/racket-chez-scheme-bin-sh.patch: Refresh patch. * gnu/packages/patches/racket-backport-8.6-cross-install.patch, gnu/packages/patches/racket-backport-8.6-docindex-write.patch, gnu/packages/patches/racket-backport-8.6-hurd.patch: New patches. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/racket.scm (%racket-origin)[patches]: Use them and the patches for Zuo. (%racket-version): Update to 8.6. (zuo)[version]: Refer to '%racket-version'. [origin]: Use '%racket-origin'. (racket-vm-cgc)[native-inputs]: Add 'zuo'. [arguments]<#:make-flags>: Use 'zuo' from 'native-inputs'. (racket)[inputs]<data, db, deinprogramm, draw, drracket, errortrace, gui, htdp, math, option-contract, parser-tools, pict, rackunit, realm, redex, scribble, typed-racket, string-constants, swindle, syntax-color, web-server>: Update checksums. * gnu/packages/chez.scm (target-chez-os): Handle Hurd and QNX. (%chez-features-table): Likewise. (chez-scheme-for-racket): Update to 9.5.9.2. [native-inputs]: Add 'zuo'. [arguments]<#:out-of-source?>: Use out-of-source build. <#:tests?>: Skip them due to ongoing problems. <#:configure-flags>: Add '--install-csug=' and '--installreleasenotes='. <#:make-flags>: Use 'zuo' from 'native-inputs'. Supply 'STEXLIB=' here, rather than in a phase. <#:phases>: Replace 'install-docs' using new 'make' target. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm52
1 files changed, 47 insertions, 5 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index c627c4d842..b59398578a 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -115,7 +115,7 @@ in Chez Scheme machine types, or '#f' if none is defined."
((target-linux? system)
"le")
((target-hurd? system)
- #f)
+ "gnu")
((target-mingw? system)
"nt")
;; missing (guix utils) predicates
@@ -131,6 +131,8 @@ in Chez Scheme machine types, or '#f' if none is defined."
;; Nix says "x86_64-solaris", but accommodate "-solaris2"
((string-contains system "solaris")
"s2")
+ ((string-suffix? "-qnx" system)
+ "qnx")
;; unknown
(else
#f)))
@@ -167,6 +169,9 @@ in Chez Scheme machine types, or '#f' if none is defined."
("arm32" bootstrap-bootfiles)
("arm64" . #f)
("ppc32" threads))
+ ;; Hurd
+ ("gnu"
+ ("i3" . #f))
;; FreeBSD
("fb"
("i3" threads) ;; commented out
@@ -192,6 +197,9 @@ in Chez Scheme machine types, or '#f' if none is defined."
("s2"
("i3" threads) ;; commented out
("a6" threads)) ;; commented out
+ ;; QNX
+ ("qnx"
+ ("i3" . #f))
;; Windows
("nt"
("i3" threads bootstrap-bootfiles)
@@ -433,7 +441,7 @@ and 32-bit PowerPC architectures.")
(package
(inherit chez-scheme)
(name "chez-scheme-for-racket")
- (version "9.5.7.6")
+ (version "9.5.9.2")
;; The version should match `(scheme-fork-version-number)`.
;; See racket/src/ChezScheme/s/cmacros.ss c. line 360.
;; It will always be different than the upstream version!
@@ -444,18 +452,52 @@ and 32-bit PowerPC architectures.")
(delete "libx11" "util-linux:lib")))
(native-inputs
(modify-inputs (package-native-inputs chez-scheme)
+ (prepend zuo)
(replace "chez-scheme-bootstrap-bootfiles"
chez-scheme-for-racket-bootstrap-bootfiles)))
(arguments
(substitute-keyword-arguments (package-arguments chez-scheme)
+ ((#:out-of-source? _ #f)
+ #t)
+ ((#:tests? _ #t)
+ ;; FIXME: There have been some flaky test failures. Some have been
+ ;; fixed upstream post-release but have proven non-trivial to
+ ;; backport; at least one issue remains. Re-enable tests once
+ ;; https://github.com/racket/racket/issues/4359 is fixed.
+ #f)
((#:configure-flags cfg-flags #~'())
- #~(cons* "--disable-x11"
- "--threads" ;; ok to potentially duplicate
- #$cfg-flags))
+ #~`("--disable-x11"
+ "--threads" ;; ok to potentially duplicate
+ ,@(let* ((chez+version (strip-store-file-name #$output))
+ (doc-prefix (assoc-ref %outputs "doc"))
+ (doc-dir (string-append doc-prefix
+ "/share/doc/"
+ chez+version)))
+ (list (string-append "--installcsug="
+ doc-dir
+ "/csug")
+ (string-append "--installreleasenotes="
+ doc-dir
+ "/release_notes")))
+ ,@#$cfg-flags))
+ ((#:make-flags mk-flags #~'())
+ #~(cons* (string-append "ZUO="
+ #+(this-package-native-input "zuo")
+ "/bin/zuo")
+ (string-append "STEXLIB="
+ #+(this-package-native-input "stex")
+ "/lib/stex")
+ #$mk-flags))
((#:phases those-phases #~%standard-phases)
#~(let* ((those-phases #$those-phases)
(unpack (assoc-ref those-phases 'unpack)))
(modify-phases those-phases
+ (replace 'install-docs
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke
+ "make"
+ "install-docs"
+ make-flags)))
(replace 'unpack
(lambda args
(unpack #:source #$(or (package-source this-package)