summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-08-27 14:55:49 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:12 +0200
commit47da722838d2c8f33692a2d6930a156dc2554060 (patch)
treed97f50d48000e0e07ec92e3331a5387e06a393d2 /gnu/packages/chez.scm
parent9647296ce618fbc79026534c3fafb1a538612697 (diff)
gnu: chez-scheme: Make bootfiles regular inputs.
* gnu/packages/chez.scm (chez-scheme)[native-inputs]: Move 'chez-scheme-bootstrap-bootfiles' to ... [inputs]: ... this field. [arguments]<#:phases>: Update 'unpack-bootfiles' accordingly. (chez-scheme-for-racket)[native-inputs]: Move 'chez-scheme-for-racket-bootstrap-bootfiles' to ... [inputs]: ... this field. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index b59398578a..c87786c091 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -293,6 +293,7 @@ Otherwise, SYSTEM can use only the ``portable bytecode'' backends."
(build-system gnu-build-system)
(inputs
(list
+ chez-scheme-bootstrap-bootfiles
`(,util-linux "lib") ;<-- libuuid
zlib
lz4
@@ -300,8 +301,7 @@ Otherwise, SYSTEM can use only the ``portable bytecode'' backends."
;; for X11 clipboard support in expeditor:
;; https://github.com/cisco/ChezScheme/issues/9#issuecomment-222057232
libx11))
- (native-inputs (list chez-scheme-bootstrap-bootfiles
- chez-nanopass-bootstrap
+ (native-inputs (list chez-nanopass-bootstrap
stex-bootstrap))
(native-search-paths
(list (search-path-specification
@@ -338,7 +338,7 @@ Otherwise, SYSTEM can use only the ``portable bytecode'' backends."
(when (directory-exists? "boot")
(delete-file-recursively "boot"))
(copy-recursively
- (search-input-directory (or native-inputs inputs)
+ (search-input-directory inputs
"lib/chez-scheme-bootfiles")
"boot")))
;; NOTE: The custom Chez 'configure' script doesn't allow
@@ -449,12 +449,12 @@ and 32-bit PowerPC architectures.")
(source #f) ; avoid problematic cycle with racket.scm
(inputs
(modify-inputs (package-inputs chez-scheme)
- (delete "libx11" "util-linux:lib")))
+ (delete "libx11" "util-linux:lib")
+ (replace "chez-scheme-bootstrap-bootfiles"
+ chez-scheme-for-racket-bootstrap-bootfiles)))
(native-inputs
(modify-inputs (package-native-inputs chez-scheme)
- (prepend zuo)
- (replace "chez-scheme-bootstrap-bootfiles"
- chez-scheme-for-racket-bootstrap-bootfiles)))
+ (prepend zuo)))
(arguments
(substitute-keyword-arguments (package-arguments chez-scheme)
((#:out-of-source? _ #f)