summaryrefslogtreecommitdiff
path: root/gnu/packages/chicken.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-28 20:20:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-15 20:17:36 +0200
commit44bb5507d63b89c9d5f0c2c77af94caeec96e5e6 (patch)
treeb9ddbd0c01379707d49060dc2e5c61cd3b3beb33 /gnu/packages/chicken.scm
parentad9adec6b464520180bf023358b655385030c397 (diff)
gnu: Add chicken-args.
* gnu/packages/chicken.scm (chicken-args): New variable.
Diffstat (limited to 'gnu/packages/chicken.scm')
-rw-r--r--gnu/packages/chicken.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index b87b8118f1..3ae4c7210c 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -329,3 +329,23 @@ primitives. More specifically, provided are:
@end itemize
@end itemize")
(license license:bsd-3)))
+
+(define-public chicken-args
+ (package
+ (name "chicken-args")
+ (version "1.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (egg-uri "args" version))
+ (sha256
+ (base32
+ "0knkg31d4dq9a8rq9g3ycmj0z6j9l7zp93qa9cnqc8ixd6jsymkm"))))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "args"))
+ (propagated-inputs (list chicken-srfi-1 chicken-srfi-13 chicken-srfi-37))
+ (home-page "https://wiki.call-cc.org/egg/args")
+ (synopsis "Command-line argument handling, on top of SRFI 37")
+ (description "This extension provides a wrapper around
+SRFI-37 (args-fold). The main goal is to let the user parse command-line
+arguments without having to write a lot of similar support code every time.")
+ (license license:bsd-3)))