summaryrefslogtreecommitdiff
path: root/gnu/packages/chicken.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-16 02:23:11 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-16 02:26:55 +0200
commit5b351982c2a90b72520e992799d012823edfeeb7 (patch)
treea7ac48800c90b5de65bd2007fe9bf81b14a34f84 /gnu/packages/chicken.scm
parent154d2700129c189a4995c34b412d0472aeb76025 (diff)
Revert "gnu: Add chicken-args."
This reverts commit 44bb5507d63b89c9d5f0c2c77af94caeec96e5e6, which references a package that does not exist, thus breaking “guix pull”.
Diffstat (limited to 'gnu/packages/chicken.scm')
-rw-r--r--gnu/packages/chicken.scm20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 3ae4c7210c..b87b8118f1 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -329,23 +329,3 @@ primitives. More specifically, provided are:
@end itemize
@end itemize")
(license license:bsd-3)))
-
-(define-public chicken-args
- (package
- (name "chicken-args")
- (version "1.6.2")
- (source (origin
- (method url-fetch)
- (uri (egg-uri "args" version))
- (sha256
- (base32
- "0knkg31d4dq9a8rq9g3ycmj0z6j9l7zp93qa9cnqc8ixd6jsymkm"))))
- (build-system chicken-build-system)
- (arguments '(#:egg-name "args"))
- (propagated-inputs (list chicken-srfi-1 chicken-srfi-13 chicken-srfi-37))
- (home-page "https://wiki.call-cc.org/egg/args")
- (synopsis "Command-line argument handling, on top of SRFI 37")
- (description "This extension provides a wrapper around
-SRFI-37 (args-fold). The main goal is to let the user parse command-line
-arguments without having to write a lot of similar support code every time.")
- (license license:bsd-3)))