summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-11 23:36:10 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 23:36:10 +0200
commit77eb3008e350c069e0ae8df6a91bf0ebdcfc2ac0 (patch)
treeb899e65aa79099be3f4b27dfcd565bb143681211 /gnu/packages/chromium.scm
parentf7e8be231806a904e6817e8ab3404b32f2511db2 (diff)
parentb50eaa67642ebc25e9c896f2e700c08610e0a5da (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 7e75ba8418..c91a8f250c 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -316,7 +316,7 @@
;; run the Blink performance tests, just remove everything to save ~70MiB.
'("third_party/blink/perf_tests"))
-(define %chromium-version "103.0.5060.134")
+(define %chromium-version "104.0.5112.81")
(define %ungoogled-revision (string-append %chromium-version "-1"))
(define %debian-revision "debian/102.0.5005.61-1")
@@ -328,7 +328,7 @@
(file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
(sha256
(base32
- "00mpmyaa8bqxf1f4vhk1waxhjbhcwab8m1x1vf341al64f6bmr1r"))))
+ "0dvwh470h06x5a4p8kw22pi4lvch16knh90i2kh10y0wfggqz78w"))))
(define %debian-origin
(origin
@@ -477,7 +477,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
- "0wdmy15602qxrb403p8yyx69k7py85fbawdsgap1l6z4h4j2g2p4"))
+ "0x17jzzvn2aqx3ahqyi6ijyn70sn79kg648r0ks9m5gib1bbgf0y"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)
@@ -509,7 +509,6 @@
"disable_fieldtrial_testing_config=true"
"safe_browsing_mode=0"
"enable_mdns=false"
- "enable_one_click_signin=false"
"enable_reading_list=false"
"enable_remoting=false"
"enable_reporting=false"
@@ -596,6 +595,12 @@
;; This include path is added by Debians openjpeg patch.
(("/usr/include/openjpeg-2.4") openjpeg))
+ ;; Remove contrib/ prefix from minizip header inclusions.
+ (substitute* (find-files "third_party/tflite_support\
+/src/tensorflow_lite_support/metadata/cc")
+ (("contrib/minizip/")
+ "minizip/"))
+
(substitute*
'("base/process/launch_posix.cc"
"base/third_party/dynamic_annotations/dynamic_annotations.c"
@@ -790,6 +795,7 @@
"chrome_200_percent.pak"
"resources.pak"
"v8_context_snapshot.bin"
+ "chrome_crashpad_handler"
;; Swiftshader ICD.
"libvk_swiftshader.so"