summaryrefslogtreecommitdiff
path: root/gnu/packages/ci.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-03-10 08:41:10 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-03-10 08:49:47 +0100
commitff52d1156c249ce8906972941a92e1816f86e395 (patch)
tree85e4dbca61a56a32029de9608d88b83b36eea6aa /gnu/packages/ci.scm
parent0d5e2c587f5ac58f7a4f810629692e05255c804c (diff)
gnu: cuirass: Update to 0.0.1-73.14e1335.
* gnu/packages/ci.scm (cuirass): Update to 0.0.1-73.14e1335. [arguments]: Enable tests and add new 'set-PATH-for-tests phase. [native-inputs]: Add ephemeralpg.
Diffstat (limited to 'gnu/packages/ci.scm')
-rw-r--r--gnu/packages/ci.scm68
1 files changed, 39 insertions, 29 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index 5fa800be4a..bf1346f628 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -66,20 +66,21 @@
(file-name (string-append name "-" version "-checkout")))))))
(define-public cuirass
- (let ((commit "543e26addc6e2304611e2feb8dd3a5a0646507b6")
- (revision "72"))
+ (let ((commit "14e1335732271fdce730cb7e5043429ea9155201")
+ (revision "73"))
(package
(name "cuirass")
(version (git-version "0.0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/git/guix/guix-cuirass.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "01cxg0nwafzfg0phbv1b4cv24w7yaalkkdib3qfwf6jqagbfg85y"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/guix/guix-cuirass.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xv2c4x1zbsf7ifwkmf1fjbbgbbdv33d8qx6b6iw9nnfr2022fqa"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -87,9 +88,14 @@
(ice-9 rdelim)
(ice-9 popen))
#:configure-flags '("--localstatedir=/var") ;for /var/log/cuirass
- #:tests? #f ;requires a PostgreSQL database.
#:phases
(modify-phases %standard-phases
+ (add-before 'check 'set-PATH-for-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pg (assoc-ref inputs "ephemeralpg"))
+ (path (getenv "PATH")))
+ (setenv "PATH" (string-append pg "/bin:" path))
+ #t)))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Wrap the 'cuirass' command to refer to the right modules.
@@ -110,22 +116,25 @@
(deps (list avahi gcrypt json zmq squee git bytes
fibers zlib matd tls mail guix))
(guile (assoc-ref %build-inputs "guile"))
- (effective (read-line
- (open-pipe* OPEN_READ
- (string-append guile "/bin/guile")
- "-c" "(display (effective-version))")))
- (mods (string-drop-right ;drop trailing colon
- (string-join deps
- (string-append "/share/guile/site/"
- effective ":")
- 'suffix)
- 1))
- (objs (string-drop-right
- (string-join deps
- (string-append "/lib/guile/" effective
- "/site-ccache:")
- 'suffix)
- 1)))
+ (effective
+ (read-line
+ (open-pipe* OPEN_READ
+ (string-append guile "/bin/guile")
+ "-c" "(display (effective-version))")))
+ (mods
+ (string-drop-right ;drop trailing colon
+ (string-join deps
+ (string-append "/share/guile/site/"
+ effective ":")
+ 'suffix)
+ 1))
+ (objs
+ (string-drop-right
+ (string-join deps
+ (string-append "/lib/guile/" effective
+ "/site-ccache:")
+ 'suffix)
+ 1)))
;; Make sure 'cuirass' can find the 'evaluate' command, as
;; well as the relevant Guile modules.
(for-each
@@ -157,7 +166,8 @@
`(("autoconf" ,autoconf)
("automake" ,automake)
("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)))
+ ("texinfo" ,texinfo)
+ ("ephemeralpg" ,ephemeralpg)))
(native-search-paths
;; For HTTPS access, Cuirass itself honors these variables, with the
;; same semantics as Git and OpenSSL (respectively).