summaryrefslogtreecommitdiff
path: root/gnu/packages/clifm.scm
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2023-11-14 23:22:21 +0400
committerLudovic Courtès <ludo@gnu.org>2023-11-22 16:51:46 +0100
commit42aabf9dac744ccb4ece315e2d7e058b8410f17e (patch)
treefb3841ded2b4cd69dc8ebedd4b0cea06f2f26402 /gnu/packages/clifm.scm
parentf40f9178e665bce158e24eeb5fd1592cdb9dc374 (diff)
gnu: Add clifm.
* gnu/packages/clifm.scm (clifm): New variable * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Change-Id: Iba6929365aabdc779d42dcde08e826efc7288664
Diffstat (limited to 'gnu/packages/clifm.scm')
-rw-r--r--gnu/packages/clifm.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/clifm.scm b/gnu/packages/clifm.scm
new file mode 100644
index 0000000000..92d14f1072
--- /dev/null
+++ b/gnu/packages/clifm.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Rodion Goritskov <rodion.goritskov@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages clifm)
+ #:use-module (guix packages)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages acl)
+ #:use-module (gnu packages linux))
+
+(define-public clifm
+ (package
+ (name "clifm")
+ (version "1.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/leo-arch/clifm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1r9pxlyn8jg0wmzbmbc71l42098lz5k32k6yid09yz6d0gaax7g1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (delete 'check))))
+ (inputs (list readline acl libcap))
+ (home-page "https://github.com/leo-arch/clifm")
+ (synopsis "Command-line file manager")
+ (description "Clifm a shell-like, text-based terminal file manager that
+sits on the command line.
+
+It is built with command line principles in mind: instead of navigating
+through a big menu of files, it lets you type, exactly as you do in your
+regular shell, but easier and faster.")
+ (license license:gpl2+)))