summaryrefslogtreecommitdiff
path: root/gnu/packages/cluster.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-08 21:42:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-08 21:42:45 +0200
commitae9fb02bb5364dce2a7995253216d28485c19e64 (patch)
tree9ac9f6626096b0fb6bd84a9f9b21658f9c968cba /gnu/packages/cluster.scm
parentda6486010ab1ac5f6c67764bb599385026b7fe15 (diff)
gnu: drbd-utils: Enable building on more architectures.
* gnu/packages/cluster.scm (drbd-utils)[arguments]: Only generate the man-pages on systems which support ruby-asciidoctor. [native-inputs]: Only include docbook-xml, docbook-xml-4.4, docbook-xsl, libxml2, libxslt, ruby-asciidoctor on systems which support ruby-asciidoctor. Change-Id: I7d45a1fbcb87d3847dfd49b4efdb80961f1f6a22
Diffstat (limited to 'gnu/packages/cluster.scm')
-rw-r--r--gnu/packages/cluster.scm43
1 files changed, 25 insertions, 18 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 1b38015372..f342d159e1 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Dion Mendel <guix@dm9.info>
+;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,14 +75,18 @@
(arguments
(list
#:configure-flags
- #~(list "--sysconfdir=/etc"
- "--localstatedir=/var"
- ;; Do not install sysv or systemd init scripts.
- "--with-initscripttype=none"
- ;; Disable support for DRBD 8.3 as it is only for
- ;; Linux-Libre versions < 3.8. 8.4 is the latest
- ;; kernel driver as of Linux 5.18.
- "--without-83support")
+ #~(append
+ (list "--sysconfdir=/etc"
+ "--localstatedir=/var"
+ ;; Do not install sysv or systemd init scripts.
+ "--with-initscripttype=none"
+ ;; Disable support for DRBD 8.3 as it is only for
+ ;; Linux-Libre versions < 3.8. 8.4 is the latest
+ ;; kernel driver as of Linux 5.18.
+ "--without-83support")
+ #$(if (this-package-native-input "ruby-asciidoctor")
+ #~'()
+ #~(list "--without-manual")))
#:test-target "test"
#:make-flags #~(list "WANT_DRBD_REPRODUCIBLE_BUILD=yesplease")
#:phases
@@ -126,16 +131,18 @@
(("\\$\\(DESTDIR\\)\\$\\(DRBD_LIB_DIR\\)")
"$(DESTDIR)$(prefix)$(DRBD_LIB_DIR)")))))))
(native-inputs
- (list clitest
- eudev ;just to satisfy a configure check
- flex
- ;; For the documentation.
- docbook-xml
- docbook-xml-4.4 ;used by documentation/ra2refentry.xsl
- docbook-xsl
- libxml2 ;for XML_CATALOG_FILES
- libxslt ;for xsltproc
- ruby-asciidoctor))
+ (append (list clitest
+ eudev ;just to satisfy a configure check
+ flex)
+ ;; For the documentation.
+ (if (supported-package? ruby-asciidoctor)
+ (list docbook-xml
+ docbook-xml-4.4 ;used by documentation/ra2refentry.xsl
+ docbook-xsl
+ libxml2 ;for XML_CATALOG_FILES
+ libxslt ;for xsltproc
+ ruby-asciidoctor)
+ '())))
(home-page "https://www.linbit.com/drbd/")
(synopsis "Replicate block devices between machines")
(description