summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-10-14 17:21:26 +0200
committerLudovic Courtès <ludo@gnu.org>2023-10-24 00:02:14 +0200
commit356ca40c8980c8d4eea4d211955e21c8de35e8fd (patch)
tree343b72fa57cd129fc3203d41c4fd009ab381d89e /gnu/packages/cmake.scm
parent2fbb5398a39bf18e41235891a0740fa0bc4d7a4d (diff)
gnu: cmake-minimal: Remove ‘hidden’ property.
This makes ‘cmake-minimal’ accessible to users and additionally allows for input rewriting, as discussed at <https://issues.guix.gnu.org/65665#17>. * gnu/packages/cmake.scm (cmake-minimal)[properties]: New field.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index bc14286070..1592703f8d 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -263,6 +263,7 @@ and workspaces that can be used in the compiler environment of your choice.")
(package
(inherit cmake-bootstrap)
(name "cmake-minimal")
+ (properties (alist-delete 'hidden? (package-properties cmake-bootstrap)))
(source (origin
(inherit (package-source cmake-bootstrap))
;; Purge CMakes bundled dependencies as they are no longer needed.