summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-27 21:21:25 +0200
committerMarius Bakke <marius@gnu.org>2022-06-27 23:48:00 +0200
commit9dfd2ad73b80b7eb363b02930f20cc63396ab966 (patch)
tree88d19f91990e368b73df21ece90cf325095b37ee /gnu/packages/cmake.scm
parent2ada32cc3963afd7f195cb82eade3baf0df2cf1f (diff)
gnu: CMake: Bootstrap with system jsoncpp.
* gnu/packages/cmake.scm (cmake-bootstrap)[arguments]: Remove "--no-system-jsoncpp" from #:configure-flags. [inputs]: Add JSONCPP. (cmake-minimal)[inputs]: Remove.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index cf930c57fc..b581217685 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -171,7 +171,6 @@ using the CMake build system.")
(string-append "--parallel=" parallel-job-count)
(string-append "--prefix=" out)
"--system-libs"
- "--no-system-jsoncpp"
;; By default, the man pages and other docs land
;; in PREFIX/man and PREFIX/doc, but we want them
;; in share/{man,doc}. Note that unlike
@@ -218,6 +217,7 @@ using the CMake build system.")
("curl" ,curl)
("expat" ,expat)
("file" ,file)
+ ("jsoncpp" ,jsoncpp)
("libarchive" ,libarchive)
,@(if (hurd-target?)
'()
@@ -284,9 +284,6 @@ and workspaces that can be used in the compiler environment of your choice.")
"Utilities"
lstat)
#t))))
- (inputs
- (modify-inputs (package-inputs cmake-bootstrap)
- (prepend jsoncpp)))
(build-system cmake-build-system)
(arguments
`(#:configure-flags