summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-27 22:13:22 +0200
committerMarius Bakke <marius@gnu.org>2022-06-27 23:48:01 +0200
commit0b0750e83144dc59b3c01f72c98c23c890e8de5b (patch)
tree6935f7274b6b44755106869290c30d777ee3d723 /gnu/packages/cmake.scm
parentb1fa242cb1f6a35eb4999ffa80fb574b9fb50fd3 (diff)
gnu: CMake: Update to 3.23.2.
* gnu/packages/cmake.scm (cmake-bootstrap): Update to 3.23.2. (%preserved-third-party-files): Preserve bundled ELF header files. * gnu/packages/patches/cmake-curl-certificates.patch: Adjust for upstream changes.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index fe49bdf0fa..00ea7c3054 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -142,6 +142,8 @@ using the CMake build system.")
;; be available along with the required headers.
"Utilities/cmlibarchive/libarchive/archive_getdate.c"
"Utilities/cmlibarchive/libarchive/archive_getdate.h"
+ ;; ELF headers.
+ "Utilities/cmelf"
;; CMake header wrappers.
"Utilities/cm3p"))
@@ -150,7 +152,7 @@ using the CMake build system.")
(define-public cmake-bootstrap
(package
(name "cmake-bootstrap")
- (version "3.21.4")
+ (version "3.23.2")
(source (origin
(method url-fetch)
(uri (string-append "https://cmake.org/files/v"
@@ -158,7 +160,7 @@ using the CMake build system.")
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "0y2rk316j9m1iqimgwah0z1ii3ggli65dw6hdn4ckx0mqaahlmyr"))
+ "1ai6zycs4zj49d46lzz9b6l0q5hvlkyix66zd90rlvs6ac0b85pk"))
(patches (search-patches "cmake-curl-certificates.patch"))))
(build-system gnu-build-system)
(arguments