summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2023-05-22 12:11:01 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-22 17:05:18 +0200
commit88a2871d8f82a7280486c2a30cc9b510ee8b2b5c (patch)
tree4f08975cf8e7101c081fb7416faa8673d70aee56 /gnu/packages/code.scm
parent849286ba66c96534bddc04df1a47d5692cbc977e (diff)
gnu: lcov: Patch reference to 'find' command.
Fixes <https://issues.guix.gnu.org/63517>. Reported by Luca Cirrottola <luca.cirrottola@inria.fr>. * gnu/packages/code.scm (lcov)[arguments]: Rename 'patch-pwd' phase to 'patch-references-to-commands', and patch reference to 'find'.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index d57954c47c..9cdda2b751 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2018, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2019-2023 Efraim Flashner <efraim@flashner.co.il>
@@ -562,16 +562,19 @@ stack traces.")
(assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-pwd
- ;; Lift the requirement of having a shell in PATH.
- (lambda _
+ (add-after 'unpack 'patch-references-to-commands
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Lift the requirement of having a shell and 'find' in PATH.
(substitute* "bin/geninfo"
(("qw/abs_path/")
"qw/abs_path getcwd/"))
(substitute* '("bin/lcov" "bin/geninfo")
(("`pwd`")
- "getcwd()"))
- #t))
+ "getcwd()")
+ (("`find ")
+ (string-append "`"
+ (search-input-file inputs "/bin/find")
+ " ")))))
(delete 'configure) ;no configure script
(add-after 'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)