summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-15 15:11:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-15 15:11:15 +0200
commit37399b18ef70f2b32c50ea45b3bfa649bbf58f16 (patch)
treeccdd4aead4bae65076f4a0d88d9a1c0396f965c0 /gnu/packages/commencement.scm
parent62ff0b90864c8a4484aa2f14856ff33d05e00b0c (diff)
gnu: coreutils-boot0: Fix building on armhf-linux.
* gnu/packages/commencement.scm (coreutils-boot0)[arguments]: When building for armhf-linux include the workaround to force 32-bit time. Rearrange arguments so that the configure-flags for armhf-linux aren't overridden.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c1a40c999b..e390bf98aa 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1999,6 +1999,8 @@ exec " gcc "/bin/" program
(arguments
`(#:tests? #f
#:implicit-inputs? #f
+ #:guile ,%bootstrap-guile
+ ,@(package-arguments coreutils)
;; The %bootstrap-glibc for aarch64 and armhf doesn't have
;; $output/include/linux/prctl.h which causes some binaries
;; to fail to build with coreutils-9.0+.
@@ -2008,10 +2010,11 @@ exec " gcc "/bin/" program
;; the defaults to not install.
"arch,coreutils,hostname"
;; fails due to missing headers.
- ",timeout,sort")))
- '())
- #:guile ,%bootstrap-guile
- ,@(package-arguments coreutils)))))
+ ",timeout,sort")
+ ,@(if (target-arm32?)
+ `("--disable-year2038")
+ `())))
+ '())))))
(define diffutils-boot0
(package