summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2023-12-24 20:30:02 +0100
committerChristopher Baines <mail@cbaines.net>2024-07-11 10:24:15 +0100
commite110e972e55246751ac4c5fbd557f70d34d2f509 (patch)
treea2d4544afcb83b250b9a9f6063e71d03da8310e4 /gnu/packages/commencement.scm
parentfd28a5200849dc58f7218c66ef0e9420d54737f9 (diff)
gnu: mes-boot: Update to 0.25.1.
* gnu/packages/commencement.scm(mes-boot): Update to 0.25.1. [arguments]: Adjust the 'configure phase to allow for other systems. Adjust the 'build phase. [supported-systems]: Add riscv64-linux. Change-Id: I262a8b6855e8c6528969d0c4b69a42cd2f477f2d Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 02c0e78b07..322aef3ddf 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages xml)
#:use-module (guix gexp)
#:use-module (guix packages)
+ #:use-module (guix platform)
#:use-module ((guix store) #:select (%store-monad))
#:use-module (guix monads)
#:use-module (guix download)
@@ -373,11 +374,12 @@ the way up: hex1, catm, hex2, M0, cc_x86, M1, M2, get_machine (that's all of
MesCC-Tools), and finally M2-Planet.")
(license license:gpl3+)))
+
(define mes-boot
(package
(inherit mes)
(name "mes-boot")
- (version "0.24.2")
+ (version "0.25.1")
(source (origin
(method url-fetch)
(uri (list (string-append "mirror://gnu/mes/"
@@ -386,10 +388,10 @@ MesCC-Tools), and finally M2-Planet.")
"mes-" version ".tar.gz")))
(sha256
(base32
- "0vp8v88zszh1imm3dvdfi3m8cywshdj7xcrsq4cgmss69s2y1nkx"))))
+ "03np6h4qx94givjdvq2rmhvab38y5f91254n0avg4vq2j0cx78in"))))
(inputs '())
(propagated-inputs '())
- (supported-systems '("i686-linux" "x86_64-linux"))
+ (supported-systems '("i686-linux" "x86_64-linux" "riscv64-linux"))
(native-inputs
`(("m2-planet" ,stage0-posix)
("nyacc-source" ,(bootstrap-origin
@@ -418,9 +420,17 @@ MesCC-Tools), and finally M2-Planet.")
dir "/nyacc-1.00.2/module"))
(invoke "gash" "configure.sh"
(string-append "--prefix=" out)
- "--host=i686-linux-gnu"))))
+ (string-append "--host="
+ #$(cond
+ ((target-x86-64?) "i686-linux-gnu")
+ (#t (platform-system->target
+ (%current-system)))))))))
(replace 'build
(lambda _
+ ;; TODO: GUILE_LOAD_PATH is leaking. We need to clean it.
+ (substitute* "kaem.run"
+ (("cp bin/mes-m2 bin/mes" all)
+ (string-append "GUILE_LOAD_PATH=/fubar\n" all)))
(invoke "gash" "bootstrap.sh")))
(delete 'check)
(replace 'install