summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-29 20:10:38 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-19 07:32:33 +0200
commitc1840e9442f7e69fa864553346e3af1c4c4f5ada (patch)
tree55b632c9c30c5f8df19a8297ac219b58136cd306 /gnu/packages/commencement.scm
parent5315c237020ae7d7fc3a9ac3fc72e7b99c5b75c9 (diff)
gnu: commencement: mig-boot0: Update to 1.8+git20230520.
* gnu/packages/commencement.scm (mig-boot0): Remove redundant outer let. [name]: New field, give proper name. [version]: New field [source]: Update to 1.8+git20230520. [native-inputs]: Add autoconf-boot0, automake-boot0. [inputs]: Add gnumach-headers-boot0.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b4d02ac9cd..f2d3b96c1a 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2695,17 +2695,21 @@ memoized as a function of '%current-system'."
(("long_natural_t") "unsigned long")))))))))))
(define mig-boot0
- (let* ((mig (package
- (inherit (package-with-bootstrap-guile mig))
- (native-inputs `(("bison" ,bison-boot0)
- ("flex" ,flex-boot0)))
- (inputs `(("flex" ,flex-boot0)))
- (arguments
- ;; TODO: On next rebuild cycle, reuse phases from 'mig'.
- `(#:configure-flags
- `(,(string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %build-inputs "flex") "/lib/")))))))
- (with-boot0 mig)))
+ (with-boot0
+ (package
+ (inherit mig)
+ (name "mig-boot0")
+ (version "1.8+git20230520")
+ (source (origin (inherit (package-source mig))))
+ (native-inputs (list autoconf-boot0 automake-boot0 bison-boot0 flex-boot0
+ gnumach-headers-boot0))
+ (inputs (list flex-boot0 gnumach-headers-boot0))
+ (arguments
+ (list
+ #:configure-flags
+ #~(list (string-append "LDFLAGS=-Wl,-rpath="
+ #$(this-package-native-input "flex")
+ "/lib/")))))))
(define hurd-version-boot0 "0.9-229-ga1efcee8")
(define hurd-source-boot0