summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-08 23:10:50 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-08 23:27:08 +0200
commit34d624cef51f0e4eb4e888622b60fc2befe31fa7 (patch)
treec75a68670184f4a7275edf82454a213843d537a9 /gnu/packages/commencement.scm
parent27695e22df089e560995a5bcd503fac8011ead05 (diff)
gnu: Build derivations with Guile 2.2 by default.
* gnu/packages/guile.scm (guile-2.0/fixed): Remove. (guile-2.2)[source]: Switch from tar.lz to tar.xz. (guile-2.2/fixed): New variable. * gnu/packages/commencement.scm (guile-final): Use GUILE-2.2/FIXED instead of GUILE-2.2/FIXED. (canonical-package): Mention 2.2 instead of 2.0.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 92f6e6c2ea..09a82b6b94 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -821,7 +821,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; This package must be public because other modules refer to it. However,
;; mark it as hidden so that 'fold-packages' ignores it.
(package-with-bootstrap-guile
- (package-with-explicit-inputs (hidden-package guile-2.0/fixed)
+ (package-with-explicit-inputs (hidden-package guile-2.2/fixed)
%boot4-inputs
(current-source-location)
#:guile %bootstrap-guile)))
@@ -940,7 +940,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
the implicit inputs of 'gnu-build-system', return that one, otherwise return
PACKAGE.
-The goal is to avoid duplication in cases like GUILE-FINAL vs. GUILE-2.0,
+The goal is to avoid duplication in cases like GUILE-FINAL vs. GUILE-2.2,
COREUTILS-FINAL vs. COREUTILS, etc."
;; XXX: This doesn't handle dependencies of the final inputs, such as
;; libunistring, GMP, etc.