summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-14 15:40:35 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-14 15:40:35 +0200
commit62548232711b2f34fa6a03caee2b3cf082c99ada (patch)
treefde78df34f5ca3f154e30907f2a07210deb56002 /gnu/packages/commencement.scm
parente5c1f5cfdfe0ba4c0893779e7c5103edb6843465 (diff)
gnu: bison-boot0: Remove conditional parallel build/test flags.
* gnu/packages/commencement.scm (bison-boot0)[arguments]: Remove conditional #:parallel-build? and #:parallel-tests? flags. Append (package-arguments bison).
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1e30027c49..26b0a94c74 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1730,17 +1730,6 @@ exec " gcc "/bin/" program
#:implicit-inputs? #f
#:guile ,%bootstrap-guile
- ;; XXX: These flags should be unconditional, but for now
- ;; we just add them on x86 to avoid a full rebuild.
- ;; TODO: On the next core-updates, use
- ;; 'substitute-keyword-arguments' to inherit them from
- ;; BISON.
- ,@(if (member (%current-system)
- '("x86_64-linux" "i686-linux"))
- '(#:parallel-build? #f
- #:parallel-tests? #f)
- '())
-
;; Zero timestamps in liby.a; this must be done
;; explicitly here because the bootstrap Binutils don't
;; do that (default is "cru".)
@@ -1751,7 +1740,9 @@ exec " gcc "/bin/" program
"RANLIB=ranlib")
(_
"RANLIB=ranlib -D"))
- "V=1")))))
+ "V=1")
+
+ ,@(package-arguments bison)))))
(define flex-boot0
;; This Flex is needed to build MiG as well as Linux-Libre headers.