summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-01-02 21:07:59 +0200
committerManolis Ragkousis <manolis837@gmail.com>2017-01-03 16:00:39 +0200
commit62596a158b4878e3f4b64f3e0f3a3f846228afd4 (patch)
treeaba9fdbf72f5ea1806285d561bbe71c1b1a42cb5 /gnu/packages/commencement.scm
parent6a37872cd2c132371ef2cb5344e004c63fdeb927 (diff)
gnu: Use hurd-triplet? to check if GNU/Hurd.
* gnu/packages/make-bootstrap.scm (hurd-triplet?): Move it from here.. * gnu/packages/hurd.scm: ..to here. New exported procedure. * gnu/packages/commencement.scm (glibc-final-with-bootstrap-bash) [arguments]: Replace string-match. [inputs]: Same. * gnu/packages/cross-base.scm (cross-libc)[native-inputs]: Same.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c7aa59e9a2..7df1d3fca9 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -474,7 +474,7 @@ the bootstrap environment."
(unsetenv "CPATH")
;; Tell 'libpthread' where to find 'libihash' on Hurd systems.
- ,@(if (string-match "i586-gnu" (%current-system))
+ ,@(if (hurd-triplet? (%current-system))
`((substitute* "libpthread/Makefile"
(("LDLIBS-pthread.so =.*")
(string-append "LDLIBS-pthread.so = "
@@ -499,7 +499,7 @@ the bootstrap environment."
,@%boot1-inputs
;; A native MiG is needed to build Glibc on Hurd.
- ,@(if (string-match "i586-gnu" (%current-system))
+ ,@(if (hurd-triplet? (%current-system))
`(("mig" ,mig-boot0))
'())