summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-18 23:57:11 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-18 23:57:11 +0100
commitf1e0c85ad23071ea5b1dbcee1474ec34a5de7422 (patch)
tree521a938b17e70913e18725201f48566b53ea1532 /gnu/packages/commencement.scm
parent32243bfb57aa5d280b4949954af2df9c93b327e1 (diff)
gnu: commencement: Build the final Bash with "bison-boot1".
This removes a round of Bison + Flex + M4 + Perl rebuild. * gnu/packages/commencement.scm (bash-final): Add 'native-inputs' field pointing to BISON-BOOT1.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 7c13ecf598..32facf2f47 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -662,11 +662,13 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define bash-final
;; Link with `-static-libgcc' to make sure we don't retain a reference
;; to the bootstrap GCC.
- (package-with-bootstrap-guile
- (package-with-explicit-inputs (static-libgcc-package bash)
- %boot3-inputs
- (current-source-location)
- #:guile %bootstrap-guile)))
+ (package
+ (inherit (package-with-bootstrap-guile
+ (package-with-explicit-inputs (static-libgcc-package bash)
+ %boot3-inputs
+ (current-source-location)
+ #:guile %bootstrap-guile)))
+ (native-inputs `(("bison" ,bison-boot1)))))
(define %boot4-inputs
;; Now use the final Bash.