summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/compression.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm93
1 files changed, 49 insertions, 44 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index bfdd76abe9..88c6979464 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
-;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
@@ -53,6 +53,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages compression)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix packages)
@@ -397,8 +398,10 @@ decompression.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'unpack-gnulib
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gnulib (assoc-ref inputs "gnulib")))
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (let ((gnulib
+ (dirname (search-input-file (or native-inputs inputs)
+ "gnulib-tool.py"))))
(copy-recursively gnulib "lib")
(setenv "PATH" (string-append "lib:" (getenv "PATH")))
#t)))
@@ -616,14 +619,14 @@ archiving. Lzip is a clean implementation of the LZMA algorithm.")
(define-public lziprecover
(package
(name "lziprecover")
- (version "1.22")
+ (version "1.23")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/lziprecover/"
"lziprecover-" version ".tar.gz"))
(sha256
(base32
- "0qh8dnhr5rly2k9dnx43qqynqwqzi5kfb15pyd29qwppfl4qm5gx"))))
+ "0wmmyi03fv2lflsir5ldrsv04q57k3hmlqajzb1m3p86gwbh967j"))))
(build-system gnu-build-system)
(home-page "https://www.nongnu.org/lzip/lziprecover.html")
(synopsis "Recover and decompress data from damaged lzip files")
@@ -964,31 +967,30 @@ byte-for-byte identical output.")
(define-public pigz
(package
(name "pigz")
- (version "2.6")
+ (version "2.7")
(source (origin
(method url-fetch)
(uri (string-append "http://zlib.net/pigz/"
name "-" version ".tar.gz"))
(sha256
(base32
- "0z9avc4mifwcpj3qdsf9m2rjw9jx03b2r9pj0c4xgla9fh6ppv9f"))))
+ "01y7n7lafp6maqnp4jrmasawnv67najh1bd7gjrmv3d08h1ydjdl"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (man (string-append out "/share/man/man1")))
- (install-file "pigz" bin)
- (symlink "pigz" (string-append bin "/unpigz"))
- (install-file "pigz.1" man)
- #t))))
- #:make-flags
- (list ,(string-append "CC=" (cc-for-target)))
- #:test-target "tests"))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (let* ((bin (string-append #$output "/bin"))
+ (man (string-append #$output "/share/man/man1")))
+ (install-file "pigz" bin)
+ (symlink "pigz" (string-append bin "/unpigz"))
+ (install-file "pigz.1" man)))))))
+ (native-inputs (list which))
(inputs (list zlib))
(home-page "https://zlib.net/pigz/")
(synopsis "Parallel implementation of gzip")
@@ -1072,7 +1074,7 @@ tarballs.")
(define-public libjcat
(package
(name "libjcat")
- (version "0.1.9")
+ (version "0.1.11")
(source
(origin
(method git-fetch)
@@ -1082,13 +1084,12 @@ tarballs.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "02cgznk6qdylqpcyks6qykmvhpz1pplvnxp72bjzji1y6yj3zpkj"))))
+ (base32 "08zywwhm9q8m8v17w2mp23w3w93p40ir1w4x18zrlbhs10xnhiys"))))
(build-system meson-build-system)
(native-inputs
(list gobject-introspection help2man pkg-config))
(inputs
- (list git
- glib
+ (list glib
gnupg
gnutls
gpgme
@@ -1141,14 +1142,14 @@ human-readable output.")
(define-public lrzip
(package
(name "lrzip")
- (version "0.641")
+ (version "0.651")
(source
(origin
(method url-fetch)
(uri (string-append
"http://ck.kolivas.org/apps/lrzip/lrzip-" version ".tar.xz"))
(sha256
- (base32 "0ziyanspd96dc3lp2qdcylc7aq8dhb511jhqrhxvlp502fjqjqrc"))))
+ (base32 "1y822rpl7ak57s1a4xzd6ja82cp3sff9axrpkdn5khcpn3n8vga8"))))
(build-system gnu-build-system)
(native-inputs
`(;; nasm is only required when building for 32-bit x86 platforms
@@ -1953,14 +1954,14 @@ of archives.")
(define-public lunzip
(package
(name "lunzip")
- (version "1.12")
+ (version "1.13")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/lunzip/"
"lunzip-" version ".tar.gz"))
(sha256
- (base32 "1liaynyy3qcs29hfk1pnb7i9r1mnmpw557j5v356qsv6qnm4lnz5"))))
+ (base32 "153qa674rlbw812fb7h8rfzdw4hvr6vgkjl1c0yfplj7p4h86z9w"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1980,14 +1981,14 @@ Lunzip is intended to be fully compatible with the regular lzip package.")
(define-public clzip
(package
(name "clzip")
- (version "1.12")
+ (version "1.13")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/clzip/"
"clzip-" version ".tar.gz"))
(sha256
- (base32 "1s7yidqvmxi61hh569h5aci816l6qkffjgx0zx57qyyq0qq2pjgw"))))
+ (base32 "0ypagygbnq4ppqyg7sj4816x5c1w579883m2nsq0zxbb0gszpjbs"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2006,14 +2007,14 @@ Clzip is intended to be fully compatible with the regular lzip package.")
(define-public lzlib
(package
(name "lzlib")
- (version "1.12")
+ (version "1.13")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/lzlib/"
"lzlib-" version ".tar.gz"))
(sha256
- (base32 "1c9pwd6by8is4z8bs6j306jyy6pgm2dvsn4fr7fg2b5m5qj88pcf"))))
+ (base32 "107vkzfgvb21cqq4gmxyfn97l4s2c0b3i14k9rkv594b2krmiax1"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2033,14 +2034,14 @@ corrupted input.")
(define-public plzip
(package
(name "plzip")
- (version "1.9")
+ (version "1.10")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/plzip/"
"plzip-" version ".tar.gz"))
(sha256
- (base32 "19zinpx7hssl6r3vilpvq2s7wha3545xan8b0vcvsxnyipdx3n0l"))))
+ (base32 "16408n8z21hfxp0qnx3hh1d0c47g8z9i3vflbgbrmf6qcn1abyj3"))))
(build-system gnu-build-system)
(inputs
(list lzlib))
@@ -2299,7 +2300,7 @@ reading from and writing to ZIP archives.")
(package
(inherit quazip-0)
(name "quazip")
- (version "1.2")
+ (version "1.3")
(source
(origin
(method git-fetch)
@@ -2308,7 +2309,7 @@ reading from and writing to ZIP archives.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1dwld7jxhjz9l33lrqwvklazdy7ygi6n1m4ry1n1sk5dnschrhby"))))))
+ (base32 "0njgbdm3dm5p7xic5mhppbqsl36zn83zz0xfsfh624hlk0ff7n0a"))))))
(define-public zchunk
(package
@@ -2625,7 +2626,7 @@ to their original, binary CD format.")
(define-public libdeflate
(package
(name "libdeflate")
- (version "1.8")
+ (version "1.10")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2634,7 +2635,7 @@ to their original, binary CD format.")
(file-name (git-file-name name version))
(sha256
(base32
- "0nw1zhr2s6ffcc3s0n5wsshvjb6pmybwapagli135zzn2fx1pdiz"))))
+ "0v5qh1cz787xj86l15x6brkkaw0jbxhqj5f85275q0l945qazvwm"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -2642,6 +2643,10 @@ to their original, binary CD format.")
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'skip-static-library-installation
+ (lambda _
+ (substitute* "Makefile"
+ (("install .*\\$\\(STATIC_LIB\\).*") ""))))
(delete 'configure))))
(inputs
(list zlib))
@@ -2689,7 +2694,7 @@ can append files to the end of such compressed archives.")
(define-public libcbor
(package
(name "libcbor")
- (version "0.8.0")
+ (version "0.9.0")
(source
(origin
(method git-fetch)
@@ -2697,7 +2702,7 @@ can append files to the end of such compressed archives.")
(url "https://github.com/PJK/libcbor")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (sha256 (base32 "01dv4vxcmbvpphqy16vqiwh25wx11x630js5wfnx7cryarsh9ld7"))))
+ (sha256 (base32 "1n9fx5i81wr9j18bhz74wclfkwqf1k3piq6lzngvkmq04krzi7ss"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -2711,8 +2716,8 @@ can append files to the end of such compressed archives.")
(string-append "-DCMAKE_INSTALL_RPATH=" lib)))))
(synopsis "The C library for parsing and generating CBOR")
(description
- "The Concise Binary Object Representation (CBOR) is a data format whose
-design goals include the possibility of extremely small code size, fairly
+ "@acronym{CBOR, The Concise Binary Object Representation} is a data format
+whose design goals include the possibility of extremely small code size, fairly
small message size, and extensibility without the need for version
negotiation. These design goals make it different from earlier binary
serializations such as ASN.1 and MessagePack.")