summaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
commit7bf4ce4582cd2f9c5b30c547262c1c4a426c0b9b (patch)
treec6f9cc83feaaf685b7542a98e60bc24ea7c297b1 /gnu/packages/containers.scm
parent06d01c610e3bee61e38a177aecda5982d5b338ae (diff)
parent92d8b4c9598ed32cdb6630433d5914c1ae8b7146 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm103
1 files changed, 46 insertions, 57 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index a3aa9ac1db..2b5acdc3bc 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2023 Zongyuan Li <zongyuan.li@c0x0o.me>
;;; Copyright © 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,62 +54,50 @@
#:use-module (gnu packages wget))
(define-public crun
- (let ((commit "c381048530aa750495cf502ddb7181f2ded5b400"))
- (package
- (name "crun")
- (version "1.4.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/containers/crun")
- (commit commit)
- (recursive? #t)))
- (sha256
- (base32 "0x2xmr5sv9ivvcv5fl5jjk4kq9b3n97s5hsqiqfwl4rz8qcz4xk1"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags '("--disable-systemd")
- #:tests? #f ; XXX: needs /sys/fs/cgroup mounted
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'do-not-depend-on-git
- (lambda _
- (substitute* "autogen.sh"
- (("^git submodule update.*")
- ""))
- (with-output-to-file "git-version.h"
- (lambda ()
- (display (string-append
- "/* autogenerated. */\n#ifndef GIT_VERSION\n# define GIT_VERSION \""
- ,commit
- "\"\n#endif\n"))))))
- (add-after 'unpack 'fix-tests
- (lambda _
- (substitute* (find-files "tests" "\\.(c|py)")
- (("/bin/true") (which "true"))
- (("/bin/false") (which "false"))
- ; relies on sd_notify which requires systemd?
- (("\"sd-notify\" : test_sd_notify,") "")
- (("\"sd-notify-file\" : test_sd_notify_file,") "")))))))
- (inputs
- (list libcap
- libseccomp
- yajl))
- (native-inputs
- (list automake
- autoconf
- git
- libtool
- pkg-config
- python-3))
- (home-page "https://github.com/containers/crun")
- (synopsis "Open Container Initiative (OCI) Container runtime")
- (description
- "crun is a fast and low-memory footprint Open Container Initiative (OCI)
+ (package
+ (name "crun")
+ (version "1.14.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/containers/crun/releases/download/"
+ version
+ "/crun-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02lplc2asyllb58mvy7l8b9gsk7fxs95g928xk28yzmf592ay33x"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-systemd")
+ #:tests? #f ; XXX: needs /sys/fs/cgroup mounted
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* (find-files "tests" "\\.(c|py)")
+ (("/bin/true") (which "true"))
+ (("/bin/false") (which "false"))
+ ; relies on sd_notify which requires systemd?
+ (("\"sd-notify\" : test_sd_notify,") "")
+ (("\"sd-notify-file\" : test_sd_notify_file,") "")))))))
+ (inputs
+ (list libcap
+ libseccomp
+ yajl))
+ (native-inputs
+ (list automake
+ autoconf
+ git
+ libtool
+ pkg-config
+ python-3))
+ (home-page "https://github.com/containers/crun")
+ (synopsis "Open Container Initiative (OCI) Container runtime")
+ (description
+ "crun is a fast and low-memory footprint Open Container Initiative (OCI)
Container Runtime fully written in C.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public conmon
(package
@@ -221,7 +210,7 @@ containers or various tools.")
(define-public slirp4netns
(package
(name "slirp4netns")
- (version "1.2.0")
+ (version "1.2.3")
(source
(origin
(method git-fetch)
@@ -229,7 +218,7 @@ containers or various tools.")
(url "https://github.com/rootless-containers/slirp4netns")
(commit (string-append "v" version))))
(sha256
- (base32 "1rlzwp5fx1x3q179j9s2jp02imjag5pgj333z110nrvi7azl22l8"))
+ (base32 "0czvdsdv821fz4jd9rgrlkdhhjna6frawr8klvx3k2cfh444fbii"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments