summaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 15:21:09 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 15:27:12 +0000
commitb24c1bab470f991fa29bdd7d2bda12b30d4eb126 (patch)
tree0f7c55beffd7c718e819c34c2579b3cbddb3d03c /gnu/packages/containers.scm
parent6002e9e7711136373de5a6325769e9c7d11032c9 (diff)
gnu: crun: Adjust package ideation.
The release package provides the configured version, so there is no need to use git commit to adjust version detection. * gnu/packages/containers.scm (crun): Remove let and indent the package. [arguments] <#:phases>: Remove 'do-no-depend-on-git phase as the package includes release version. Change-Id: Ie50fe1f5f8ed69a77e353033679bfd98db6e56f4
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm98
1 files changed, 43 insertions, 55 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index c321448439..2b5acdc3bc 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -54,62 +54,50 @@
#:use-module (gnu packages wget))
(define-public crun
- (let ((commit "de537a7965bfbe9992e2cfae0baeb56a08128171"))
- (package
- (name "crun")
- (version "1.14.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/containers/crun/releases/download/"
- version
- "/crun-" version ".tar.gz"))
- (sha256
- (base32
- "02lplc2asyllb58mvy7l8b9gsk7fxs95g928xk28yzmf592ay33x"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags '("--disable-systemd")
- #:tests? #f ; XXX: needs /sys/fs/cgroup mounted
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'do-not-depend-on-git
- (lambda _
- (substitute* "autogen.sh"
- (("^git submodule update.*")
- ""))
- (with-output-to-file "git-version.h"
- (lambda ()
- (display (string-append
- "/* autogenerated. */\n#ifndef GIT_VERSION\n# define GIT_VERSION \""
- ,commit
- "\"\n#endif\n"))))))
- (add-after 'unpack 'fix-tests
- (lambda _
- (substitute* (find-files "tests" "\\.(c|py)")
- (("/bin/true") (which "true"))
- (("/bin/false") (which "false"))
- ; relies on sd_notify which requires systemd?
- (("\"sd-notify\" : test_sd_notify,") "")
- (("\"sd-notify-file\" : test_sd_notify_file,") "")))))))
- (inputs
- (list libcap
- libseccomp
- yajl))
- (native-inputs
- (list automake
- autoconf
- git
- libtool
- pkg-config
- python-3))
- (home-page "https://github.com/containers/crun")
- (synopsis "Open Container Initiative (OCI) Container runtime")
- (description
- "crun is a fast and low-memory footprint Open Container Initiative (OCI)
+ (package
+ (name "crun")
+ (version "1.14.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/containers/crun/releases/download/"
+ version
+ "/crun-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02lplc2asyllb58mvy7l8b9gsk7fxs95g928xk28yzmf592ay33x"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-systemd")
+ #:tests? #f ; XXX: needs /sys/fs/cgroup mounted
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* (find-files "tests" "\\.(c|py)")
+ (("/bin/true") (which "true"))
+ (("/bin/false") (which "false"))
+ ; relies on sd_notify which requires systemd?
+ (("\"sd-notify\" : test_sd_notify,") "")
+ (("\"sd-notify-file\" : test_sd_notify_file,") "")))))))
+ (inputs
+ (list libcap
+ libseccomp
+ yajl))
+ (native-inputs
+ (list automake
+ autoconf
+ git
+ libtool
+ pkg-config
+ python-3))
+ (home-page "https://github.com/containers/crun")
+ (synopsis "Open Container Initiative (OCI) Container runtime")
+ (description
+ "crun is a fast and low-memory footprint Open Container Initiative (OCI)
Container Runtime fully written in C.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public conmon
(package