summaryrefslogtreecommitdiff
path: root/gnu/packages/cook.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-15 19:26:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-15 19:26:55 +0200
commitbd21acf6c390e4fe87eb6053f0b5185d6ecbcf9f (patch)
tree09fe91a8351471e5e7a821cb28521dd9b9d7e357 /gnu/packages/cook.scm
parenta4f1a7e2db22cd028fb514846c2791928b8734d3 (diff)
parentb44e19acd1a0d449427cea0333f02ac98605be1c (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/cook.scm')
-rw-r--r--gnu/packages/cook.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/cook.scm b/gnu/packages/cook.scm
index 16c288cc82..ba13709eda 100644
--- a/gnu/packages/cook.scm
+++ b/gnu/packages/cook.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,13 @@
(substitute* "test/00/t0077a.sh"
(("ar qc") "ar qcU"))
+ ;; Guix builds have LC_ALL set to "en_US.utf8", which causes
+ ;; `date` to use a 12-hour clock instead of 24h, which in turn
+ ;; makes t0217a.sh fail because of unexpected date output.
+ (substitute* "test/02/t0217a.sh"
+ (("export TZ")
+ "export TZ\nLC_ALL=POSIX\nexport LC_ALL"))
+
(setenv "SH" (which "sh"))
#t)))))
(native-inputs `(("bison" ,bison)