summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2023-06-16 15:02:45 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-09-02 09:26:28 +0200
commitcf2a8755db2c77df490fd29a5bcc5afa139a7a2b (patch)
tree31c9a211055088d0d744ad91bc9455d2922249e7 /gnu/packages/cpp.scm
parent2c37b33796ac768e24853c5f813420e3bf1569c7 (diff)
gnu: Add optional-lite.
* gnu/packages/cpp.scm (optional-lite): New variable.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5402e333f5..72f04b25a0 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2376,6 +2376,29 @@ parsing with only a single memory allocation.")
((#:tests? _ #f) #f)))
(properties '((hidden? . #t)))))
+(define-public optional-lite
+ (package
+ (name "optional-lite")
+ (version "3.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martinmoene/optional-lite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jpsm94kp1504yk9s2km86zv8xrszz30qanmhz2ljmvsdblz2l47"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/martinmoene/optional-lite")
+ (synopsis "Nullable object for C++98, C++11 and later")
+ (description
+ "Optional lite is a single-file header-only library to represent optional
+(nullable) objects and pass them by value. The library aims to provide a
+C++17-like optional for use with C++98 and later. If available,
+@code{std::optional} is used.")
+ (license license:boost1.0)))
+
(define-public optionparser
(package
(name "optionparser")