summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-09-13 20:26:38 +0000
committerLudovic Courtès <ludo@gnu.org>2022-09-14 23:36:31 +0200
commitec883398f6e074195e3de0fccb95b5f594fefe89 (patch)
tree276e89139037405efa21e87a0b485accbd3dd760 /gnu/packages/cpp.scm
parent7944fb5ffeab46c7349e89279a695ca8e2381960 (diff)
gnu: xsimd-benchmark: Build example.
* gnu/packages/cpp.scm (xsimd-benchmark): Fix package name. [arguments]<#:configure-flags>: Enable examples ... <#:phases>{install} ... and install. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8aea2e2441..6289c9520f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -456,12 +456,12 @@ operating on batches.")
library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
(license license:asl2.0)))
-(define-public xsmimd-benchmark
+(define-public xsimd-benchmark
(package
(inherit xsimd)
(name "xsimd-benchmark")
(arguments
- `(#:configure-flags (list "-DBUILD_BENCHMARK=ON")
+ `(#:configure-flags (list "-DBUILD_BENCHMARK=ON" "-DBUILD_EXAMPLES=ON")
#:tests? #f
#:phases (modify-phases %standard-phases
(add-after 'unpack 'remove-march=native
@@ -470,9 +470,11 @@ library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
(("-march=native") ""))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- ;; Install nothing but the executable.
+ ;; Install nothing but the executables.
(let ((out (assoc-ref outputs "out")))
(install-file "benchmark/benchmark_xsimd"
+ (string-append out "/bin"))
+ (install-file "examples/mandelbrot"
(string-append out "/bin"))))))))
(synopsis "Benchmark of the xsimd library")