summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-01-02 18:48:03 -0500
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-31 09:22:46 +0100
commit6bacfa63c10a277b559373f29f68723cfb31b0e9 (patch)
tree0b2162b709a7a301d9a00fd2f5902ef3f6d1b37e /gnu/packages/cpp.scm
parenta20b4f07bf90efa21acd035d9830bd8f4bf4240d (diff)
gnu: Add c++-gsl.
* gnu/packages/cpp.scm (c++-gsl): New variable. * gnu/packages/patches/c++-gsl-find-system-gtest.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 73a3ceb2df..d19712275c 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -63,6 +63,35 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
+(define-public c++-gsl
+ (package
+ (name "c++-gsl")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/microsoft/GSL.git")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (patches
+ (search-patches
+ "c++-gsl-find-system-gtest.patch"))
+ (sha256
+ (base32 "0gbvr48f03830g3154bjhw92b8ggmg6wwh5xyb8nppk9v6w752l0"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Guidelines Support Library")
+ (description "c++-gsl contains functions and types that are suggested for
+use by the C++ Core Guidelines maintained by the Standard C++ Foundation.")
+ (home-page "https://github.com/microsoft/GSL/")
+ (license license:expat)))
+
(define-public libzen
(package
(name "libzen")