summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-02-23 12:39:15 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-02-23 12:39:15 +0100
commitb4f28584d3b2844a91fe9690c8437b5b260d3cc1 (patch)
tree9246b527302602ce23ef69ce9856d530d8c29e1c /gnu/packages/cpp.scm
parent0de0074844f3391c7c85537f66bfcab288dce8dc (diff)
gnu: cli11: Remove (guix utils) dependency.
* gnu/packages/cpp.scm (cli11)[arguments]: Do not import (guix utils) that is not meant to go on the build side.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index abb50d81b2..685dc02fca 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -928,17 +928,18 @@ conversions to and from strings, iteration and related functionality.")
`(#:configure-flags
'("-DCLI11_SINGLE_FILE=OFF"
"-DCLI11_BUILD_EXAMPLES=OFF")
- #:imported-modules ,(append %cmake-build-system-modules
- (source-module-closure '((guix utils))))
+ #:imported-modules ,%cmake-build-system-modules
+ #:modules ((guix build cmake-build-system)
+ (guix build utils))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'no-vendor-gtest
(lambda _
- (use-modules (guix utils))
(substitute* "tests/CMakeLists.txt"
- ;; We provide our own googletest, so this is not really a problem.
- (("message\\(FATAL_ERROR \"You have requested tests be built, but googletest is not downloaded." msg)
- (string-replace-substring msg "FATAL_ERROR" "TRACE")))
+ ;; We provide our own googletest, so this is not really a
+ ;; problem.
+ (("message\\(FATAL_ERROR \"You have requested")
+ "message(TRACE \"You have requested"))
(substitute* "cmake/AddGoogletest.cmake"
(("^add_subdirectory\\(.*googletest.*$") "find_package(GTest REQUIRED)")
(("^set_target_properties\\(gtest gtest_main gmock gmock_main") "")