summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-04-28 21:55:13 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-14 12:22:29 +0200
commitf8d06e2c32abc86832925929794448690784348c (patch)
treea9d1080da8e0f3faa1f432430a5964afc2d945a6 /gnu/packages/cpp.scm
parent4a3f94640841285aa43ca1a00e540069f7148a63 (diff)
gnu: nlohmann-json: Improve package style.
* gnu/package/cpp.scm (nlohmann-json)[source]<snippet>: Fit to 80 chars width. Use G-Expressions. [arguments]: Use G-Expressions.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm70
1 files changed, 37 insertions, 33 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 886199af5e..27fa9048ab 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -611,41 +611,45 @@ data transfer object.")
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
- '(begin
- ;; Delete bundled software. Preserve doctest_compatibility.h, which
- ;; is a wrapper library added by this package.
- (install-file "./tests/thirdparty/doctest/doctest_compatibility.h" "/tmp")
- (delete-file-recursively "./tests/thirdparty")
- (install-file "/tmp/doctest_compatibility.h" "./tests/thirdparty/doctest")
-
- ;; Adjust for the unbundled fifo_map and doctest.
- (substitute* (find-files "./tests/" "\\.h(pp)?")
- (("#include \"doctest\\.h\"") "#include <doctest/doctest.h>")
- (("#include <doctest\\.h>") "#include <doctest/doctest.h>"))
- (with-directory-excursion "tests/src"
- (let ((files (find-files "." "\\.cpp$")))
- (substitute* files
- (("#include ?\"(fifo_map.hpp)\"" all fifo-map-hpp)
- (string-append
- "#include <fifo_map/" fifo-map-hpp ">")))))))))
+ #~(begin
+ ;; Delete bundled software. Preserve doctest_compatibility.h, which
+ ;; is a wrapper library added by this package.
+ (install-file "./tests/thirdparty/doctest/doctest_compatibility.h"
+ "/tmp")
+ (delete-file-recursively "./tests/thirdparty")
+ (install-file "/tmp/doctest_compatibility.h"
+ "./tests/thirdparty/doctest")
+
+ ;; Adjust for the unbundled fifo_map and doctest.
+ (substitute* (find-files "./tests/" "\\.h(pp)?")
+ (("#include \"doctest\\.h\"") "#include <doctest/doctest.h>")
+ (("#include <doctest\\.h>") "#include <doctest/doctest.h>"))
+ (with-directory-excursion "tests/src"
+ (let ((files (find-files "." "\\.cpp$")))
+ (substitute* files
+ (("#include ?\"(fifo_map.hpp)\"" all fifo-map-hpp)
+ (string-append
+ "#include <fifo_map/" fifo-map-hpp ">")))))))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
- (list "-DJSON_MultipleHeaders=ON" ; For json_fwd.hpp.
- (string-append "-DJSON_TestDataDirectory="
- (dirname
- (search-input-directory %build-inputs
- "json_nlohmann_tests"))))
- #:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
- (if tests?
- ;; Some tests need git and a full checkout, skip those.
- (invoke "ctest" "-LE" "git_required"
- "-j" (if parallel-tests?
- (number->string (parallel-job-count))
- "1"))
- (format #t "test suite not run~%")))))))
+ (list
+ #:configure-flags
+ #~(list "-DJSON_MultipleHeaders=ON" ; For json_fwd.hpp.
+ (string-append "-DJSON_TestDataDirectory="
+ (dirname
+ (search-input-directory %build-inputs
+ "json_nlohmann_tests"))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (if tests?
+ ;; Some tests need git and a full checkout, skip those.
+ (invoke "ctest" "-LE" "git_required"
+ "-j" (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (format #t "test suite not run~%")))))))
(native-inputs
(list amalgamate
(let ((version "3.1.0"))