summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 13:09:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 13:09:32 +0200
commit1b48d723bd70b90b8526697debb1805994cbe431 (patch)
tree31b4a619b1e5b4af68271f27320d4d121fe71812 /gnu/packages/cran.scm
parentc31eea21ddb48bc66635b2681017e7e5e055fd59 (diff)
gnu: Add r-logistf.
* gnu/packages/cran.scm (r-logistf): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 589bcd8f30..4229fc2cea 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19443,6 +19443,37 @@ hierarchic loggers, multiple handlers per logger, level based filtering, space
handling in messages and custom formatting.")
(license license:gpl3)))
+(define-public r-logistf
+ (package
+ (name "r-logistf")
+ (version "1.25.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "logistf" version))
+ (sha256
+ (base32
+ "0w78jsynw5jh3l9r3ssjs8rza6givgrxzwnb5jwazcm8637d6gix"))))
+ (properties `((upstream-name . "logistf")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-formula-tools r-matrix r-mgcv r-mice))
+ (home-page
+ "https://cemsiis.meduniwien.ac.at/en/kb/science-research\
+/software/statistical-software/firth-correction/")
+ (synopsis "Firth's bias-reduced logistic regression")
+ (description
+ "Fit a logistic regression model using Firth's bias reduction method,
+equivalent to penalization of the log-likelihood by the Jeffreys prior.
+Confidence intervals for regression coefficients can be computed by penalized
+profile likelihood. Firth's method was proposed as ideal solution to the
+problem of separation in logistic regression, see Heinze and Schemper (2002)
+<doi:10.1002/sim.1047>. If needed, the bias reduction can be turned off such
+that ordinary maximum likelihood logistic regression is obtained. Two new
+modifications of Firth's method, FLIC and FLAC, lead to unbiased predictions
+and are now available in the package as well, see Puhr et al (2017)
+<doi:10.1002/sim.7273>.")
+ ;; Any version of the GPL
+ (license license:gpl3+)))
+
(define-public r-longdat
(package
(name "r-longdat")