summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-15 14:00:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-15 14:12:22 +0100
commit28bee49404384558063e38c98e3193d0676b11c9 (patch)
tree7e9bac7ec17c1781212e79bb42584a5520cc77c4 /gnu/packages/cran.scm
parent7151086affd9f435969bc925951c572d8d2e6956 (diff)
gnu: Add r-secretbase.
* gnu/packages/cran.scm (r-secretbase): New variable. Change-Id: I66aa67e5f09f030dce90f2a114e3a7893549ca2e
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3b8ad2baac..2f6608fe01 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3870,6 +3870,25 @@ designed to work with @code{magrittr} to make it easy to express common web
scraping tasks, inspired by libraries like @code{BeautifulSoup}.")
(license license:gpl3)))
+(define-public r-secretbase
+ (package
+ (name "r-secretbase")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "secretbase" version))
+ (sha256
+ (base32 "1z0ddzdimma8rgd47fn5mma09d5c7vrl5b7gdlvfk8l047yihyb6"))))
+ (properties `((upstream-name . "secretbase")))
+ (build-system r-build-system)
+ (home-page "https://shikokuchuo.net/secretbase/")
+ (synopsis "Cryptographic Hash and Extendable-Output Functions")
+ (description
+ "This package provides implementations of the SHA-3 cryptographic hash
+and SHAKE256 extendable-output functions (XOF).")
+ (license license:gpl3+)))
+
(define-public r-selectr
(package
(name "r-selectr")