summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-14 10:24:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-14 10:25:00 +0100
commit2ba2875dbda4b080fcad4e6d672bb4104d59dd0c (patch)
treeb246b863678ccbbc4a484cc8db1e3a8333bb2208 /gnu/packages/cran.scm
parentac470c516e19f194228edf9e348bdbc7fc10f97a (diff)
gnu: Add r-box.
* gnu/packages/cran.scm (r-box): New variable. Change-Id: I5dc6f0ffae3dc3540d431f2533493f1eb82f75b7
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 407e64ae05..3b8ad2baac 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -192,6 +192,27 @@ estimating equations} (GEE) or @dfn{generalized linear mixed effect
models} (GLMM).")
(license license:gpl2+)))
+(define-public r-box
+ (package
+ (name "r-box")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "box" version))
+ (sha256
+ (base32 "00g5ik3f6260m38jl8k4s8nycmy7mzdwr7qslrl66phpg84xzmln"))))
+ (properties `((upstream-name . "box")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://klmr.me/box/")
+ (synopsis "Write reusable, composable and modular R code")
+ (description
+ "This package provides a modern module system for R. Organize code into
+hierarchical, composable, reusable modules, and use it effortlessly across
+projects via a flexible, declarative dependency loading syntax.")
+ (license license:expat)))
+
(define-public r-brio
(package
(name "r-brio")