summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
commit7bf4ce4582cd2f9c5b30c547262c1c4a426c0b9b (patch)
treec6f9cc83feaaf685b7542a98e60bc24ea7c297b1 /gnu/packages/cran.scm
parent06d01c610e3bee61e38a177aecda5982d5b338ae (diff)
parent92d8b4c9598ed32cdb6630433d5914c1ae8b7146 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm352
1 files changed, 246 insertions, 106 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 407e64ae05..fb053074a1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
@@ -116,6 +116,25 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public r-abbreviate
+ (package
+ (name "r-abbreviate")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abbreviate" version))
+ (sha256
+ (base32 "1cvjdbi17qz8gr5898zchm5fyz4n51z66lwps25v8a9mhwab8imi"))))
+ (properties `((upstream-name . "abbreviate")))
+ (build-system r-build-system)
+ (home-page "https://github.com/sigbertklinke/abbreviate")
+ (synopsis "Readable string abbreviation")
+ (description
+ "This package abbreviates strings to a specified minimum number of
+characters, such that the strings remain unique (if they originally were).")
+ (license license:gpl3)))
+
(define-public r-aer
(package
(name "r-aer")
@@ -192,6 +211,50 @@ estimating equations} (GEE) or @dfn{generalized linear mixed effect
models} (GLMM).")
(license license:gpl2+)))
+(define-public r-asioheaders
+ (package
+ (name "r-asioheaders")
+ (version "1.22.1-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AsioHeaders" version))
+ (sha256
+ (base32 "192qxayrpvi02wrqq2h5cjc92aaxrsgw7z32r8qk5imqg3mc0a8n"))))
+ (properties `((upstream-name . "AsioHeaders")))
+ (build-system r-build-system)
+ (home-page "https://github.com/eddelbuettel/asioheaders")
+ (synopsis "Asio C++ header files")
+ (description
+ "Asio is a cross-platform C++ library for network and low-level I/O
+programming that provides developers with a consistent asynchronous model
+using a modern C++ approach. It is also included in Boost but requires
+linking when used with Boost. Standalone it can be used header-only (provided
+a recent compiler). Asio is written and maintained by Christopher
+M. Kohlhoff, and released under the Boost Software License', Version 1.0.")
+ (license license:boost1.0)))
+
+(define-public r-box
+ (package
+ (name "r-box")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "box" version))
+ (sha256
+ (base32 "00g5ik3f6260m38jl8k4s8nycmy7mzdwr7qslrl66phpg84xzmln"))))
+ (properties `((upstream-name . "box")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://klmr.me/box/")
+ (synopsis "Write reusable, composable and modular R code")
+ (description
+ "This package provides a modern module system for R. Organize code into
+hierarchical, composable, reusable modules, and use it effortlessly across
+projects via a flexible, declarative dependency loading syntax.")
+ (license license:expat)))
+
(define-public r-brio
(package
(name "r-brio")
@@ -391,6 +454,27 @@ match datasets quickly. It also contains functions for various cosmological
calculations.")
(license license:gpl3)))
+(define-public r-cetcolor
+ (package
+ (name "r-cetcolor")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cetcolor" version))
+ (sha256
+ (base32 "0kygdcr9ldanr0z4qpygwh0padki7s2ad0j6myky601g4228z79q"))))
+ (properties `((upstream-name . "cetcolor")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/coatless-rpkg/cetcolor")
+ (synopsis "CET perceptually uniform color maps")
+ (description
+ "This package provides a collection of perceptually uniform color maps
+made by Peter Kovesi (2015) \"Good Colour Maps: How to Design Them\"
+<arXiv:1509.03700> at the Centre for Exploration Targeting (CET).")
+ (license license:cc-by-sa4.0)))
+
;; The package sources include multiple non-minified JavaScript files and the
;; v5.1.0 variant of d3.js. The d3.js file is not minified.
(define-public r-chromomap
@@ -453,13 +537,13 @@ labels on the node can also be achieved.")
(define-public r-collapse
(package
(name "r-collapse")
- (version "2.0.9")
+ (version "2.0.10")
(source
(origin
(method url-fetch)
(uri (cran-uri "collapse" version))
(sha256
- (base32 "0c9cz1dqrgd3gss9cr40a3rh014av0w8gfhq35lq1knyik6bhk28"))))
+ (base32 "0xary3xlkkhb3izbwzsk5q660hi00srkv95c0r36isr5bgsirfr1"))))
(properties `((upstream-name . "collapse")))
(build-system r-build-system)
(propagated-inputs (list r-rcpp))
@@ -1898,14 +1982,14 @@ similar rank-based tests for equal probability distributions due to Neuhauser
(define-public r-v8
(package
(name "r-v8")
- (version "4.4.1")
+ (version "4.4.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "V8" version))
(sha256
(base32
- "129spn531m9arz7v8vyfsrvc69hg0w39fdnhjxrcrww37l9xcvav"))))
+ "0w4n794l4f7hwwjr83112zf3cjx72q6ak0fn45qm6pqg8brkbg77"))))
(properties
`((upstream-name . "V8")
(updater-extra-inputs . ("libnode"))))
@@ -2470,14 +2554,14 @@ scale-sensitive information.")
(define-public r-ggvenndiagram
(package
(name "r-ggvenndiagram")
- (version "1.5.0")
+ (version "1.5.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggVennDiagram" version))
(sha256
(base32
- "0ngvvmz2mxh4v98wg3xqpmz1p1cpk3qsdvszcjzb1yhhway211a5"))))
+ "0hzjbpd3f3zn169s5nvnv7b4wlrwdn3r0pk0vgkdnhchl75g0qni"))))
(properties `((upstream-name . "ggVennDiagram")))
(build-system r-build-system)
(propagated-inputs
@@ -3700,13 +3784,13 @@ noisy black-box functions.")
(define-public r-tgstat
(package
(name "r-tgstat")
- (version "2.3.25")
+ (version "2.3.27")
(source
(origin
(method url-fetch)
(uri (cran-uri "tgstat" version))
(sha256
- (base32 "07hdw3n4l88nr0x2a2qnjich4cfihgd0fk65ar3crgdahjcv9vn4"))))
+ (base32 "0scljimskda5hinkb4y5va9c9qlqwf6k6zrm20bjk133710qsscb"))))
(properties `((upstream-name . "tgstat")))
(build-system r-build-system)
(native-inputs (list r-knitr))
@@ -3820,13 +3904,13 @@ cross-platform graphical user interface toolkit} widget.")
(define-public r-rvest
(package
(name "r-rvest")
- (version "1.0.3")
+ (version "1.0.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "rvest" version))
(sha256
- (base32 "07hws9infwchy19smrcd9m6c0jii0bdn335yxqk3ramgj5ryyrd4"))))
+ (base32 "19lw0jk8d8x88z247hz761gwbx9f5n3yqnv63mn7pkwl55mpqw3x"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -3837,7 +3921,6 @@ cross-platform graphical user interface toolkit} widget.")
r-rlang
r-selectr
r-tibble
- r-withr
r-xml2))
(native-inputs
(list r-knitr))
@@ -3849,6 +3932,25 @@ designed to work with @code{magrittr} to make it easy to express common web
scraping tasks, inspired by libraries like @code{BeautifulSoup}.")
(license license:gpl3)))
+(define-public r-secretbase
+ (package
+ (name "r-secretbase")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "secretbase" version))
+ (sha256
+ (base32 "1z0ddzdimma8rgd47fn5mma09d5c7vrl5b7gdlvfk8l047yihyb6"))))
+ (properties `((upstream-name . "secretbase")))
+ (build-system r-build-system)
+ (home-page "https://shikokuchuo.net/secretbase/")
+ (synopsis "Cryptographic Hash and Extendable-Output Functions")
+ (description
+ "This package provides implementations of the SHA-3 cryptographic hash
+and SHAKE256 extendable-output functions (XOF).")
+ (license license:gpl3+)))
+
(define-public r-selectr
(package
(name "r-selectr")
@@ -3988,17 +4090,17 @@ same time tries to group instances from the same class together.")
(define-public r-callr
(package
(name "r-callr")
- (version "3.7.3")
+ (version "3.7.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "callr" version))
(sha256
(base32
- "0knh5yxhxwjz96kbjrq524w4j8cac10k6mghhmblq79s0zgzwysn"))))
+ "0b277fvjglnqrjmsm4ilhqrp9sjag0r9mxls2h9v1m94ff7ix88q"))))
(build-system r-build-system)
(propagated-inputs
- (list r-r6 r-processx))
+ (list r-processx r-r6))
(home-page "https://github.com/r-lib/callr#readme")
(synopsis "Call R from R")
(description
@@ -6771,14 +6873,14 @@ validation and filtering on the values, making options invisible or private.")
(define-public r-circlize
(package
(name "r-circlize")
- (version "0.4.15")
+ (version "0.4.16")
(source
(origin
(method url-fetch)
(uri (cran-uri "circlize" version))
(sha256
(base32
- "1iswb7dy08as3pbzxvhx5qlsbnwvp79nwg8m158nfz7y2d9xa0nn"))))
+ "0rqbcmmp4h1jjl0y59bzn6k8kywjdqwvp0ajkqxd21j9f33k5p0n"))))
(build-system r-build-system)
(propagated-inputs
(list r-colorspace r-globaloptions r-shape))
@@ -7266,14 +7368,14 @@ package also provides a C++ API, that works with or without Rcpp.")
(define-public r-ggally
(package
(name "r-ggally")
- (version "2.2.0")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "GGally" version))
(sha256
(base32
- "1pc0mcxhj3mz8ac6r1sqfxw1wkamikjal54z7pb1mairsr3hpqnw"))))
+ "1il6yphqxcyj1039imi8pn6ygyni24daz8ljxxp3z9inb5k2dcwb"))))
(properties `((upstream-name . "GGally")))
(build-system r-build-system)
(inputs
@@ -8893,14 +8995,14 @@ provides a one-row summary of model-level statistics.")
(define-public r-recipes
(package
(name "r-recipes")
- (version "1.0.9")
+ (version "1.0.10")
(source
(origin
(method url-fetch)
(uri (cran-uri "recipes" version))
(sha256
(base32
- "146p9ij2i4rmzaa5v76lm7z8iaw5wqb47i9cqf4a0q7xsgqvf6hi"))))
+ "1m4v9j7by0w5avqljmwck1jsgjgwc8rsby0affa5zii3xkvvvifg"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -9509,14 +9611,14 @@ acceptance regions, log-ratio plots and Q-Q plots.")
(define-public r-sm
(package
(name "r-sm")
- (version "2.2-5.7.1")
+ (version "2.2-6.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "sm" version))
(sha256
(base32
- "0mql7rlm8wkdwmx1lv7pscdk9ibvsdpfdv8bpaz1hv2gn4pc637a"))))
+ "0q8xav1alammiyiw2p8y0qq94ag5rln910jry8q3sb2p38ly79i7"))))
(build-system r-build-system)
(native-inputs (list gfortran))
(home-page "http://www.stats.gla.ac.uk/~adrian/sm/")
@@ -10776,17 +10878,17 @@ software developed by the Statnet Project.")
(define-public r-statcheck
(package
(name "r-statcheck")
- (version "1.4.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "statcheck" version))
(sha256
(base32
- "1hibrynbgsym4hma8isby8kwb8gab9d4bx7m43qj4zayrl6b8scx"))))
+ "0gsr068if5k8124x1cbm48720l9qvnfmdg6rmh7rwh6jvxxgknd7"))))
(build-system r-build-system)
(propagated-inputs
- (list r-ggplot2 r-plyr r-rlang r-rmarkdown))
+ (list r-ggplot2 r-plyr r-rlang r-rmarkdown r-stringi))
(home-page "https://cran.r-project.org/web/packages/statcheck/")
(synopsis "Extract statistics from articles and recompute p-values")
(description "This package can automatically extract statistical
@@ -11080,14 +11182,14 @@ exhaustive search.")
(define-public r-splus2r
(package
(name "r-splus2r")
- (version "1.3-4")
+ (version "1.3-5")
(source
(origin
(method url-fetch)
(uri (cran-uri "splus2R" version))
(sha256
(base32
- "16r13bbijq7lz3c8qn7dnb4h8fc3vbcahyah2zij888p470vqljn"))))
+ "097bpzazw5ryb6izbmz2sdlghn3qvh7c7wsnn0j08j65f9bfmc77"))))
(properties `((upstream-name . "splus2R")))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/splus2R/")
@@ -11182,14 +11284,14 @@ Fisher's method), and Sidak correction.")
(define-public r-quantmod
(package
(name "r-quantmod")
- (version "0.4.25")
+ (version "0.4.26")
(source
(origin
(method url-fetch)
(uri (cran-uri "quantmod" version))
(sha256
(base32
- "0cjvz6hd4q0fd87d54wxfaka3awi9jzj8a7x72jawkdxbza9c61z"))))
+ "165vp2ygry8ibcpxjbyfvfrjbv98syln12kkyzci2ygp84r5sv1r"))))
(build-system r-build-system)
(propagated-inputs
(list r-curl r-jsonlite r-ttr r-xts r-zoo))
@@ -14201,14 +14303,14 @@ or missing responses.")
(define-public r-acdm
(package
(name "r-acdm")
- (version "1.0.4.2")
+ (version "1.0.4.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "ACDm" version))
(sha256
(base32
- "00i33b76gqllyc6ywwwrgyjvxfspqb3jf52b9sjaazlfwgn5xyjf"))))
+ "0g89827az5mnllp6l71znbvwxzygb8nvnmsv6x052w2ajhd16v7v"))))
(properties `((upstream-name . "ACDm")))
(build-system r-build-system)
(propagated-inputs
@@ -15365,14 +15467,14 @@ and coverage methods to tune the choice of threshold.")
(define-public r-ggnetwork
(package
(name "r-ggnetwork")
- (version "0.5.12")
+ (version "0.5.13")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggnetwork" version))
(sha256
(base32
- "1kg9354f39asq5baryh3zzzdl54g75mn1pxdr3pws9d2q5i8cdkl"))))
+ "0ipxw6j36n0hfn0nsimw8jbjszvm1d0hadwg4zirvn6v36npwabc"))))
(properties `((upstream-name . "ggnetwork")))
(build-system r-build-system)
(propagated-inputs
@@ -16320,14 +16422,14 @@ samples is large and the number of mixture components is not too large.")
(define-public r-magick
(package
(name "r-magick")
- (version "2.8.2")
+ (version "2.8.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "magick" version))
(sha256
(base32
- "15ja7f46f77a67wmzqfaxvhmvvzgb9yj92p2if5di7i61vlmnid1"))))
+ "0yf08ns5qgqi2bzvxvawip521ji2rgvvfrhj747zb6ci5qnm4awk"))))
(properties
'((updater-extra-inputs . ("imagemagick"))))
(build-system r-build-system)
@@ -16468,13 +16570,13 @@ were influenced by the drake R package by Will Landau (2018)
(define-public r-targets
(package
(name "r-targets")
- (version "1.4.1")
+ (version "1.5.1")
(source (origin
(method url-fetch)
(uri (cran-uri "targets" version))
(sha256
(base32
- "0kax8nj66jbcp8sbv7zl68hzf4clz5m50fibrcypnzvpamhafw1q"))))
+ "1g21cp0p5jdghr61w9q3y73jm2k248z4apn7rlxqm6m18i4x7zsb"))))
(properties `((upstream-name . "targets")))
(build-system r-build-system)
(propagated-inputs (list r-base64url
@@ -16485,8 +16587,10 @@ were influenced by the drake R package by Will Landau (2018)
r-digest
r-igraph
r-knitr
+ r-ps
r-r6
r-rlang
+ r-secretbase
r-tibble
r-tidyselect
r-vctrs
@@ -17012,14 +17116,14 @@ correlation, censored, ordered and multivariate problems.")
(define-public r-bayesplot
(package
(name "r-bayesplot")
- (version "1.11.0")
+ (version "1.11.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "bayesplot" version))
(sha256
(base32
- "0wpy1angkq513nc22fqmxsxm0y7dkvjzycy0z5s96j0z9jmb6q6n"))))
+ "0c1q1znp9vd0w6l35xa208bgiwr5f2w8j2c97v6ml4z0j5rycwag"))))
(build-system r-build-system)
(inputs
(list pandoc))
@@ -17153,14 +17257,14 @@ differentiation.")
(define-public r-bayestestr
(package
(name "r-bayestestr")
- (version "0.13.1")
+ (version "0.13.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "bayestestR" version))
(sha256
(base32
- "0mmnifi3j29qlsj917wbdqpgpk05x3cc7111k842gsv7y34h4ir7"))))
+ "15xnmjay0s9kgaj25z43cxky4qcjn3gv8yd1x548jzbxzxxma07n"))))
(properties `((upstream-name . "bayestestR")))
(build-system r-build-system)
(propagated-inputs
@@ -17180,14 +17284,14 @@ ROPE percentage and pd).")
(define-public r-performance
(package
(name "r-performance")
- (version "0.10.8")
+ (version "0.10.9")
(source
(origin
(method url-fetch)
(uri (cran-uri "performance" version))
(sha256
(base32
- "0zvj0bzbqcy35jcg1s6b1wqbz7rbajzvjm74aks4j6iq4grh4d2j"))))
+ "1qi08vwh08ndmjyx5vcpwf20j1dkj8998vz7zy26fhp1kf9dlkfw"))))
(build-system r-build-system)
(propagated-inputs
(list r-bayestestr r-datawizard r-insight))
@@ -17542,14 +17646,14 @@ User credentials are shared with command line git through the
(define-public r-usethis
(package
(name "r-usethis")
- (version "2.2.2")
+ (version "2.2.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "usethis" version))
(sha256
(base32
- "0imy9izchr9xzc5wrr91ydfr4jifv8lsqx712zkx0vxfi6kw3n6r"))))
+ "1cyy1k5iansg63ziph4w76kzl59dgmam7m2wp6sz9d93bjcrh34d"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -19756,14 +19860,14 @@ and compatibility with @code{ape} objects.")
(define-public r-rnifti
(package
(name "r-rnifti")
- (version "1.5.1")
+ (version "1.6.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "RNifti" version))
(sha256
(base32
- "0rbym1svldahd4rlbcfb5s62rigws2w1fa1f1chp504gn340b555"))))
+ "0spsdkqvlkk7xn6wz6778gc6cc7dnfcwpz91q8wdzxgcbgxdy0yv"))))
(properties `((upstream-name . "RNifti")))
(build-system r-build-system)
(inputs (list zlib))
@@ -20279,7 +20383,7 @@ preparing, executing, and processing HTTP requests.")
r-rapidjsonr
r-rlang
r-tibble))
- (home-page "https://github.com/rstats-db/bigrquery")
+ (home-page "https://github.com/r-dbi/bigrquery")
(synopsis "R interface to Google's BigQuery API")
(description
"This package provides an R interface to Google's BigQuery database.")
@@ -21209,13 +21313,13 @@ profiling R code.")
(define-public r-prospectr
(package
(name "r-prospectr")
- (version "0.2.6")
+ (version "0.2.7")
(source (origin
(method url-fetch)
(uri (cran-uri "prospectr" version))
(sha256
(base32
- "1p53hcgcs2p09zhc2n7byjzrgvcgz6w7q00mlsn4kmnz7l4p7rrm"))))
+ "0hg2afw5aixx0xdwwr6g0wi8sksn7r21hz8diyqxg2345rwnzbg4"))))
(properties `((upstream-name . "prospectr")))
(build-system r-build-system)
(propagated-inputs
@@ -21225,6 +21329,8 @@ profiling R code.")
r-mathjaxr
r-rcpp
r-rcpparmadillo))
+ (native-inputs
+ (list r-knitr))
(home-page "https://github.com/l-ramirez-lopez/prospectr")
(synopsis "Functions for processing and sample selection of spectroscopic data")
(description
@@ -21489,14 +21595,14 @@ them in distributed compute environments.")
(define-public r-parallelly
(package
(name "r-parallelly")
- (version "1.36.0")
+ (version "1.37.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "parallelly" version))
(sha256
(base32
- "123w89hmd7fn7lmdsl044npidvf7472h1ascvf7swjllan8s5h5r"))))
+ "19zrfiakg5xg51r9va4r976b4lnnsj5nsk6i6srxsl227q45xra1"))))
(properties `((upstream-name . "parallelly")))
(build-system r-build-system)
(home-page "https://github.com/HenrikBengtsson/parallelly")
@@ -22851,13 +22957,13 @@ additional utilities for genomic regions processing.")
(define-public r-setrng
(package
(name "r-setrng")
- (version "2022.4-1")
+ (version "2024.2-1")
(source (origin
(method url-fetch)
(uri (cran-uri "setRNG" version))
(sha256
(base32
- "09089vr5x8snwxh38kdhgpjl3jl7zrk056f6f9a2jg5lsrmnxh31"))))
+ "0h2wbpsi07c48h72zjglvp9b58hq3j77289sah32qg6vnw41pcp3"))))
(properties `((upstream-name . "setRNG")))
(build-system r-build-system)
(home-page "https://distr.r-forge.r-project.org/")
@@ -23070,6 +23176,29 @@ visualization of biological sequence (DNA and protein) data. It also includes
utilities for sequence data management under the ACNUC system.")
(license license:gpl2+)))
+(define-public r-unigd
+ (package
+ (name "r-unigd")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "unigd" version))
+ (sha256
+ (base32 "0519v2p4jzfpilai022blvyxi56kfdidafwjpa1g6lnmwmpk4isq"))))
+ (properties `((upstream-name . "unigd")))
+ (build-system r-build-system)
+ (inputs (list cairo fontconfig freetype libpng zlib))
+ (propagated-inputs (list r-cpp11 r-systemfonts))
+ (native-inputs (list r-knitr pkg-config))
+ (home-page "https://github.com/nx10/unigd")
+ (synopsis "Universal graphics device")
+ (description
+ "This package provides a unified R graphics backend. Render R graphics
+fast and easy to many common file formats. It provides a thread safe C
+interface for asynchronous rendering of R graphics.")
+ (license license:gpl2+)))
+
(define-public r-units
(package
(name "r-units")
@@ -23865,6 +23994,27 @@ releases/download/v0.10.1/mathquill-0.10.1.tgz")
authoring books and technical documents with R Markdown.")
(license license:gpl3)))
+(define-public r-options
+ (package
+ (name "r-options")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "options" version))
+ (sha256
+ (base32 "0pprbp2pxvgh120f8dahswws44gpdm4f4nlq3h3nvqrlhnspwnb8"))))
+ (properties `((upstream-name . "options")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://dgkf.github.io/options/")
+ (synopsis "Simple, consistent package options")
+ (description
+ "This package provides simple mechanisms for defining and interpreting
+package options. It provides helpers for interpreting environment variables,
+global options, defining default values and more.")
+ (license license:expat)))
+
(define-public r-optparse
(package
(name "r-optparse")
@@ -24502,14 +24652,14 @@ sets of URLs.")
(define-public r-ggforce
(package
(name "r-ggforce")
- (version "0.4.1")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggforce" version))
(sha256
(base32
- "0wqq8l7lq96k4w0vq12jcg7clvgia8s35jjbqq1s0py4cgxijhml"))))
+ "1a2i1rl27yqh8kxjpphwcv05p19l2aw07q9gxl4x8iv8xpkb0if1"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -24539,13 +24689,13 @@ that fills this gap.")
(define-public r-eulerr
(package
(name "r-eulerr")
- (version "7.0.0")
+ (version "7.0.1")
(source (origin
(method url-fetch)
(uri (cran-uri "eulerr" version))
(sha256
(base32
- "16a84a2xgv1iqsir0hzn6qclljni4f3prpycb7qpp06vrd0yn8lw"))))
+ "1c8yf94ga4h6rf89fyajxfsaq5z6dx1z2840371vxj7kwj9slg3c"))))
(properties `((upstream-name . "eulerr")))
(build-system r-build-system)
(propagated-inputs
@@ -26913,44 +27063,32 @@ dataset-specific factors.")
(define-public r-harmony
(package
(name "r-harmony")
- (version "0.1")
+ (version "1.2.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/immunogenomics/harmony")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (cran-uri "harmony" version))
(sha256
- (base32
- "05r401q09rbr6fqhb9mbd95082cjdi3nag1cv6zn96xkr0f6imq9"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file '("config.status" "configure"))
- #t))))
+ (base32 "1df7bb9ba3m0c44fhmh8cs4hlkh4fffjwm8rz7l87lf5pdy7sg56"))))
+ (properties `((upstream-name . "harmony")))
(build-system r-build-system)
- (propagated-inputs
- (list r-cowplot
- r-dplyr
- r-ggplot2
- r-irlba
- r-matrix
- r-rcpp
- r-rcpparmadillo
- r-rcppprogress
- r-rlang
- r-tibble
- r-tidyr))
- (native-inputs
- (list autoconf))
- (home-page "https://github.com/immunogenomics/harmony")
+ (propagated-inputs (list r-cowplot
+ r-dplyr
+ r-ggplot2
+ r-matrix
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppprogress
+ r-rhpcblasctl
+ r-rlang
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/web/packages/harmony/index.html")
(synopsis "Integration of single cell sequencing data")
(description
"This package provides an implementation of the Harmony algorithm for
-single cell integration, described in Korsunsky et al
-@url{doi.org/10.1101/461954}. The package includes a standalone Harmony
-function and interfaces to external frameworks.")
+single cell integration. This package includes a standalone Harmony function
+and interfaces to external frameworks.")
(license license:gpl3)))
(define-public r-covr
@@ -28729,13 +28867,13 @@ columns, ad allows for quick addition of extra columns to a filematrix.")
(define-public r-filesstrings
(package
(name "r-filesstrings")
- (version "3.3.0")
+ (version "3.4.0")
(source (origin
(method url-fetch)
(uri (cran-uri "filesstrings" version))
(sha256
(base32
- "0srmshjhj5yx5d81pmvr8rr1cqh8v0wsxn04bfm146yfq2pvy52h"))))
+ "0p5vgrzbvipja9lgarygqphnr1z8vy9kl9n83jnfyvf0gp4ansl2"))))
(properties `((upstream-name . "filesstrings")))
(build-system r-build-system)
(propagated-inputs (list r-checkmate
@@ -29953,14 +30091,14 @@ number embedded in the file rather than the file extension.")
(define-public r-imager
(package
(name "r-imager")
- (version "0.45.2")
+ (version "0.45.8")
(source
(origin
(method url-fetch)
(uri (cran-uri "imager" version))
(sha256
(base32
- "0mmzp55j1svlaa0lfmmaz8hijlkbk0wkv2craxhc6gyx0g5qp129"))))
+ "0vrv7m9b9w8xjqa9w17xvrmpl403476zr0l9wqdp9ir6ssvnaf2f"))))
(properties `((upstream-name . "imager")))
(build-system r-build-system)
(inputs
@@ -31317,14 +31455,14 @@ and Euclidean distance is particularly fast.")
(define-public r-isocodes
(package
(name "r-isocodes")
- (version "2023.12.07")
+ (version "2024.02.12")
(source
(origin
(method url-fetch)
(uri (cran-uri "ISOcodes" version))
(sha256
(base32
- "03nrcv1hh12yyqql03cr94kk3hnpynvrm4kv3plmdli2b3n1yqvk"))))
+ "1rp2gasiggqfaqbag8wqz1rlhlajpji2klx0rgzms21lh28ppjq2"))))
(properties `((upstream-name . "ISOcodes")))
(build-system r-build-system)
(home-page "https://cran.r-project.org/package=ISOcodes")
@@ -32125,14 +32263,14 @@ well as Ravand and Robitzsch (2015).")
(define-public r-tam
(package
(name "r-tam")
- (version "4.1-4")
+ (version "4.2-21")
(source
(origin
(method url-fetch)
(uri (cran-uri "TAM" version))
(sha256
(base32
- "0b81d0g4j94yrfzj019jffxrk1aw24iscddp60kjbkrl5p7qy38g"))))
+ "0s6mygm3sypjd393f7hsxslqwqp2s1hihb5iv8z8dhc95vj845qd"))))
(properties `((upstream-name . "TAM")))
(build-system r-build-system)
(propagated-inputs
@@ -33241,7 +33379,8 @@ filter.")
(uri (cran-uri "sglOptim" version))
(sha256
(base32
- "15bkkvgp9v9vsp65wps48g3c2fa0fj1025hbrziywq14j7wayyjr"))))
+ "15bkkvgp9v9vsp65wps48g3c2fa0fj1025hbrziywq14j7wayyjr"))
+ (patches (search-patches "r-sgloptim.patch"))))
(properties
`((upstream-name . "sglOptim")))
(build-system r-build-system)
@@ -35463,14 +35602,14 @@ model.")
(define-public r-igraph
(package
(name "r-igraph")
- (version "2.0.1.1")
+ (version "2.0.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "igraph" version))
(sha256
(base32
- "0rl8yklm7fpyjsgvjnljp6ldyj393qizi2sd5hsvmbm78h5c9dhv"))))
+ "0kfc9blyy54cz0m4mdzzwgvn0rkil49kdk438411mx62g2vxby9l"))))
(properties
`((upstream-name . "igraph")
(updater-extra-native-inputs . ("which"))))
@@ -35486,7 +35625,8 @@ model.")
r-magrittr
r-matrix
r-pkgconfig
- r-rlang))
+ r-rlang
+ r-vctrs))
(home-page "https://igraph.org")
(synopsis "Network analysis and visualization")
(description
@@ -35499,14 +35639,14 @@ more.")
(define-public r-workflows
(package
(name "r-workflows")
- (version "1.1.3")
+ (version "1.1.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "workflows" version))
(sha256
(base32
- "10a1my6glvc32zxrar1ir699lwav7iz2ji4s6g9iprjndf3nm8ms"))))
+ "120xfm12w8pfqjbmmzsyc01qnffbb1n514dgw9v9gmqdy5l70i6s"))))
(properties `((upstream-name . "workflows")))
(build-system r-build-system)
(propagated-inputs
@@ -36160,14 +36300,14 @@ analysis using @code{dplyr}, @code{ggplot2}, and other Tidy tools.")
(define-public r-parsnip
(package
(name "r-parsnip")
- (version "1.1.1")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "parsnip" version))
(sha256
(base32
- "1j0bkmv2m4rxmnpq3rqha5jccjxai11m5392hb4dgzni7in36h92"))))
+ "1wggqsvfl2kg8hx9ci6g0fsm2dw9lw6fs7kfy7sdqx6qd7r8bak0"))))
(properties `((upstream-name . "parsnip")))
(build-system r-build-system)
(propagated-inputs