summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-27 11:28:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-01 12:38:52 +0100
commite59eb3fe63a5b0b73592c7c07f85dae90d785de0 (patch)
treefa242684f35135c091e98bd98c9591ded73993dd /gnu/packages/cran.scm
parent7018092b0ea588ad04d0ae549c256dd9a480866b (diff)
gnu: Add r-leidenalg.
* gnu/packages/cran.scm (r-leidenalg): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ceb84ba823..a1da9d229e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23348,6 +23348,41 @@ graph into communities. See also Traag et al (2018) \"From Louvain to Leiden:
guaranteeing well-connected communities.\" <arXiv:1810.08473>.")
(license license:gpl3)))
+(define-public r-leidenalg
+ (package
+ (name "r-leidenalg")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "leidenAlg" version))
+ (sha256
+ (base32 "1z96zrsms93gspylmficaggb0xj94kq9rg3p2svdbb451jbga9an"))))
+ (properties `((upstream-name . "leidenAlg")))
+ (build-system r-build-system)
+ (inputs
+ (list glpk gmp libxml2))
+ (propagated-inputs
+ (list r-igraph
+ r-matrix
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-sccore))
+ (native-inputs (list gfortran))
+ (home-page "https://github.com/kharchenkolab/leidenAlg")
+ (synopsis "Leiden algorithm via an R interface")
+ (description
+ "This package implements an R interface to the Leiden algorithm, an
+iterative community detection algorithm on networks. The algorithm is
+designed to converge to a partition in which all subsets of all communities
+are locally optimally assigned, yielding communities guaranteed to be
+connected. The implementation proves to be fast, scales well, and can be run
+on graphs of millions of nodes (as long as they can fit in memory).")
+ ;; The DESCRIPTION file says GPL-3, but the code was copied from
+ ;; https://github.com/vtraag/leidenalg, which is under GPLv3+.
+ (license license:gpl3+)))
+
(define-public r-patchwork
(package
(name "r-patchwork")