summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorEric Brown <ecbrown@ericcbrown.com>2020-05-28 23:13:31 -0400
committerLeo Famulari <leo@famulari.name>2020-05-28 23:42:49 -0400
commit3bafa88b40483040e5f8034561590cadd43514c8 (patch)
treeaa2e44b031118c9dbaf6618e1c8a6e2718ac857d /gnu/packages/cran.scm
parentfa2811465b9ae5de278cfc3615c478a30eae49db (diff)
gnu: Add r-mstate.
* gnu/packages/cran.scm (r-mstate): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fb450eb25d..b27dd40871 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21778,3 +21778,29 @@ are flexible and explicitly encourage users to apply prior distributions that
actually reflect their beliefs. Model fit can easily be assessed and compared
with posterior predictive checks and leave-one-out cross-validation.")
(license license:gpl2)))
+
+(define-public r-mstate
+ (package
+ (name "r-mstate")
+ (version "0.2.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mstate" version))
+ (sha256
+ (base32
+ "0qnhivbibzss8yfsg44cvbf73n4jj4i28rbdysl88g14ig5sabgv"))))
+ (properties `((upstream-name . "mstate")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-survival" ,r-survival)))
+ (home-page
+ "https://www.lumc.nl/org/bds/research/medische-statistiek/survival-analysis/")
+ (synopsis
+ "Data Preparation, Estimation and Prediction in Multi-State Models")
+ (description
+ "Contains functions for data preparation, descriptives, hazard estimation
+and prediction with Aalen-Johansen or simulation in competing risks and
+multi-state models.")
+ (license license:gpl2+)))