summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-28 18:05:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-28 18:23:22 +0100
commit1c0c4b544deb9cd9435da5d7ace5931d2eef986b (patch)
tree0d3d153dd92113c90b3142c5533c90e140cb5847 /gnu/packages/cran.scm
parent1aa662b3094172c9f34a220d15c6ba53b9280b79 (diff)
gnu: Add r-varselrf.
* gnu/packages/cran.scm (r-varselrf): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d15516ba0d..2106b0caf9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13373,3 +13373,30 @@ The ggraph package is an extension of the ggplot2 API tailored to graph
visualizations and provides the same flexible approach to building up plots
layer by layer.")
(license license:gpl3)))
+
+(define-public r-varselrf
+ (package
+ (name "r-varselrf")
+ (version "0.7-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "varSelRF" version))
+ (sha256
+ (base32
+ "0h49rl1j13yfh97rsfsyh9s2c4wajny4rzms2qw77d0cavxqg53i"))))
+ (properties `((upstream-name . "varSelRF")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-randomforest" ,r-randomforest)))
+ (home-page "http://ligarto.org/rdiaz/Software/Software.html")
+ (synopsis "Variable selection using random forests")
+ (description
+ "This package provides tools for the variable selection from random
+forests using both backwards variable elimination (for the selection of small
+sets of non-redundant variables) and selection based on the importance
+spectrum (somewhat similar to scree plots; for the selection of large,
+potentially highly-correlated variables). The main applications are in
+high-dimensional data (e.g., microarray data, and other genomics and
+proteomics applications).")
+ (license license:gpl2+)))