summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 09:38:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 10:02:03 +0100
commit6a472af3f630aa0ea6e044c72afbe54314d25c55 (patch)
tree82c319f7fa2ff7ebd00bca03d4db9bce33e42c21 /gnu/packages/cran.scm
parent5ef7d057ed4791686ebc2c2649069cc54ca026c5 (diff)
gnu: Add r-polspline.
* gnu/packages/cran.scm (r-polspline): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fca123f5b4..7ea30dcc74 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12413,3 +12413,24 @@ datasets simultaneously. Plots can be created using global and/or individual
haplotype p-values along with single SNP p-values. Images are created as
either PDF/EPS files.")
(license license:gpl2+)))
+
+(define-public r-polspline
+ (package
+ (name "r-polspline")
+ (version "1.1.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "polspline" version))
+ (sha256
+ (base32
+ "0g4s5nwi13yfs6b169yw8vrs48nvjyc014k2v7ybcxarl8z81va0"))))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/polspline/")
+ (synopsis "Polynomial spline routines")
+ (description
+ "This package provides routines for the polynomial spline fitting
+routines hazard regression, hazard estimation with flexible tails, logspline,
+lspec, polyclass, and polymars.")
+ (license license:gpl2+)))