summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-05-23 13:41:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-23 13:48:57 +0200
commit94a8990f78be24f8f66c95f2cc5160ae4e0b6032 (patch)
tree3f2650998b9551a58f75263a8c8dc22a394a0b75 /gnu/packages/cran.scm
parente470abf8b789e61ae918a80f141e3c06afd44832 (diff)
gnu: Add r-rappdirs.
* gnu/packages/cran.scm (r-rappdirs): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d0f99aaeca..49ed877964 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3974,3 +3974,23 @@ including the ability to summarize or get a high-level view of code,
determining dependencies between variables, code improvement suggestions.")
;; Any version of the GPL
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-rappdirs
+ (package
+ (name "r-rappdirs")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rappdirs" version))
+ (sha256
+ (base32
+ "0ji6sg3bdn5gazkq14xmmcq7jnbsyxw4lzmmbgv6526j2vn93n1g"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/rappdirs/")
+ (synopsis "Determine where to save data, caches, and logs")
+ (description
+ "This package provides an easy way to determine which directories on the
+user's computer should be used to save data, caches and logs. It is a port of
+Python's @url{https://github.com/ActiveState/appdirs,Appdirs} to R.")
+ (license license:expat)))