summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-08-29 10:32:59 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-11 00:14:58 +0200
commit6c6ce2d08832ea4b854fe689ec1b3e4ac3ae60bc (patch)
tree1f8af630222e04f3206eea1796faf1837a202a5c /gnu/packages/cran.scm
parent2f195b6f23865417284883bfebc3b697270130f5 (diff)
gnu: Add r-mosaic.
* gnu/packages/cran.scm (r-mosaic): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 11822e1aa5..62d1d32669 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5583,3 +5583,43 @@ while providing the intuitive capabilities of @code{r-ggplot2}.")
"This package provides data sets from project Mosaic @url{http://mosaic-web.org}
used to teach mathematics, statistics, computation and modeling.")
(license license:gpl2+)))
+
+(define-public r-mosaic
+ (package
+ (name "r-mosaic")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mosaic" version))
+ (sha256
+ (base32 "10jbrg8kli00kfgbh2f67bymm5cnlancc9dplb1j7fl552yjddn2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggdendro" ,r-ggdendro)
+ ("r-ggformula" ,r-ggformula)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggrepel" ,r-ggrepel)
+ ("r-glue" ,r-glue)
+ ("r-gridextra" ,r-gridextra)
+ ("r-lattice" ,r-lattice)
+ ("r-latticeextra" ,r-latticeextra)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-mass" ,r-mass)
+ ("r-matrix" ,r-matrix)
+ ("r-mosaiccore" ,r-mosaiccore)
+ ("r-mosaicdata" ,r-mosaicdata)
+ ("r-readr" ,r-readr)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/ProjectMOSAIC/mosaic/")
+ (synopsis "Mathematics, statistics, and computation teaching utilities")
+ (description
+ "This package contain data sets and utilities from
+@url{http://mosaic-web.org, Project MOSAIC} used to teach mathematics,
+statistics, computation and modeling. Project MOSAIC is a community of
+educators working to tie together aspects of quantitative work that students
+in science, technology, engineering and mathematics will need in their
+professional lives, but which are usually taught in isolation, if at all.")
+ (license license:gpl2+)))