summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-05 23:20:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-06 00:14:28 +0200
commit78735b9f3440cca5187d0e7da76c899e97e8208c (patch)
treede2dcfc0d34bb9c814ecf38bb65213371613736b /gnu/packages/cran.scm
parent8128189976ad0fef5065bb3f1b552273d8990759 (diff)
gnu: Add r-grimport2.
* gnu/packages/cran.scm (r-grimport2): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 10e5e8b0d5..f66de4ac95 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9624,6 +9624,37 @@ handling.")
PostScript pictures in R plots.")
(license license:gpl2+)))
+(define-public r-grimport2
+ (package
+ (name "r-grimport2")
+ (version "0.1-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "grImport2" version))
+ (sha256
+ (base32
+ "1hwx287pp936f0wbcicplwmhz96ip00wq09dp7bvz80lqcmr8nyx"))))
+ (properties `((upstream-name . "grImport2")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-base64enc" ,r-base64enc)
+ ("r-jpeg" ,r-jpeg)
+ ("r-png" ,r-png)
+ ("r-xml" ,r-xml)))
+ (home-page "https://cran.r-project.org/web/packages/grImport2/")
+ (synopsis "Import SVG graphics")
+ (description
+ "This package provides functions for importing external vector images and
+drawing them as part of R plots. This package is different from the
+@code{grImport} package because, where that package imports PostScript format
+images, this package imports SVG format images. Furthermore, this package
+imports a specific subset of SVG, so external images must be preprocessed
+using a package like @code{rsvg} to produce SVG that this package can import.
+SVG features that are not supported by R graphics, such as gradient fills, can
+be imported and then exported via the @code{gridSVG} package.")
+ (license license:gpl2+)))
+
(define-public r-kohonen
(package
(name "r-kohonen")