summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-06 10:51:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-06 11:21:56 +0100
commita3257d427ee60ddf9d23118ad86f34fb5edb284e (patch)
treeab6e62e9c65875a71bbc7649b2353c2585e3274b /gnu/packages/cran.scm
parent18adb1f00d2586c5ffdfd804374c594a7eb47e0f (diff)
gnu: Add r-debugme.
* gnu/packages/cran.scm (r-debugme): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cb39772ae5..8e52b2a37e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -1861,3 +1861,23 @@ written purely in R with no external dependencies. It is useful with the
Rscript front-end and facilitates turning an R script into an executable
script.")
(license license:gpl3+)))
+
+(define-public r-debugme
+ (package
+ (name "r-debugme")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "debugme" version))
+ (sha256
+ (base32
+ "1c9sg55zvf10h8198jdnpamm6f66lzw3c3jnmdp9ls6na0j0xbjd"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-crayon" ,r-crayon)))
+ (home-page "https://github.com/r-lib/debugme#readme")
+ (synopsis "Debug R packages")
+ (description
+ "This package allows the user to specify debug messages as special string
+constants, and control debugging of packages via environment variables.")
+ (license license:expat)))