summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 14:42:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 16:18:41 +0100
commitf6d2b45ca8e8cf2e35d7c5f956466e63f77faf2b (patch)
treec64a8d03af22a29d1db53dac5f1d7b68864c86e2 /gnu/packages/cran.scm
parent77737e035491112a1e9c7d9a0e6f1e0397a4f930 (diff)
gnu: Add r-xfun.
* gnu/packages/cran.scm (r-xfun): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 95e0faf2a0..820df99bb2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2072,3 +2072,22 @@ around the relevant area. This work is based on the @code{ggplot2} and
dendrogram panes, and the placing of factor variables in the sides of the
heatmap.")
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-xfun
+ (package
+ (name "r-xfun")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "xfun" version))
+ (sha256
+ (base32
+ "1sm51gmwgw876d6d1q8smxmfgfh6zsnykfx8qp8z6jmh0fvd89pj"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/yihui/xfun")
+ (synopsis "Miscellaneous functions")
+ (description
+ "This package provides miscellaneous functions commonly used in other
+packages maintained by Yihui Xie.")
+ (license license:expat)))