summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-03-19 14:30:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-03-19 14:30:40 +0100
commit16855a1c9e6ee0af1f9113aebda7bfff268d4619 (patch)
tree57c5bf3825a4c48b8a154b939dabfdb4c9bf3e2d /gnu/packages/cran.scm
parentdf1cfbe439b488ec62aa8240f94784c830c67216 (diff)
gnu: r-tictoc: Update to 1.2.1.
* gnu/packages/bioinformatics.scm (r-tictoc): Move variable from here... * gnu/packages/cran.scm (r-tictoc): ...to here; update to 1.2.1. Change-Id: I3fc9dde3928a6c5cbe0e25eba8ec001c16e2b66f
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 97518abc4c..a43d78e925 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3841,6 +3841,30 @@ algorithm described in MetaCell analysis of single-cell RNA-seq
data using K-nn graph partitions.")
(license license:gpl2)))
+(define-public r-tictoc
+ (package
+ (name "r-tictoc")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "tictoc" version))
+ (sha256
+ (base32
+ "0cw8r1gn4p2v1l3d80brk9sfr9nyckyyym5nr9xq3d74l74vgkcg"))))
+ (properties `((upstream-name . "tictoc")))
+ (build-system r-build-system)
+ (home-page "https://github.com/jabiru/tictoc")
+ (synopsis
+ "Time R scripts and implementations of stack and list structures")
+ (description
+ "The tictoc package provides the timing functions @code{tic} and
+@code{toc} that can be nested. It provides an alternative to
+@code{system.time()} with a different syntax similar to that in another
+well-known software package. @code{tic} and @code{toc} are easy to use, and
+are especially useful when timing several sections in more than a few lines of
+code.")
+ (license license:asl2.0)))
+
(define-public r-tidyft
(package
(name "r-tidyft")