summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-09 18:46:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-10 15:12:28 +0200
commit467e13ce50e94cb5c646cd03c3937c97956975b1 (patch)
tree69e0766a0dddf4afe58415894f78c3cffde2deca /gnu/packages/cran.scm
parent525beb6c379352ee6e6fa7e91e3f85f41219c653 (diff)
gnu: Add r-pki.
* gnu/packages/cran.scm (r-pki): New variable. Change-Id: Ic8bd9a449b040e66093939e2d64b05e4f97f9bd3
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index df3771c214..b9ce40432b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6619,6 +6619,30 @@ attaching it. This is a key part of the @code{devtools} package as it allows
you to rapidly iterate while developing a package.")
(license license:gpl3)))
+(define-public r-pki
+ (package
+ (name "r-pki")
+ (version "0.1-12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "PKI" version))
+ (sha256
+ (base32 "0nidg6l9nrmpyimi502fydy22r247w9i4ngb2xdbxjvfhr17m0xd"))))
+ (properties `((upstream-name . "PKI")))
+ (build-system r-build-system)
+ (inputs (list openssl zlib))
+ (propagated-inputs (list r-base64enc))
+ (native-inputs (list pkg-config))
+ (home-page "http://www.rforge.net/PKI")
+ (synopsis "Public Key Infrastucture for R based on the X.509 standard")
+ (description
+ "This is a package containing Public Key Infrastucture functions such as
+verifying certificates, RSA encryption and signing, which can be used to build
+PKI infrastructure and perform cryptographic tasks.")
+ ;; Either of these licenses.
+ (license (list license:gpl2 license:gpl3))))
+
(define-public r-pvclust
(package
(name "r-pvclust")