summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-09 18:45:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-10 15:12:18 +0200
commit525beb6c379352ee6e6fa7e91e3f85f41219c653 (patch)
treef295727400d228e9dcc4a1163596ba4b20e8665a /gnu/packages/cran.scm
parentdb49eed2d3b1982c13582a8710782b4091868711 (diff)
gnu: Add r-trycatchlog.
* gnu/packages/cran.scm (r-trycatchlog): New variable. Change-Id: I092c8ada3e139e21e07f000041a5e2fc345af977
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8207f09725..df3771c214 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9683,6 +9683,27 @@ can be produced. All the probability functions in the stats, stats4 and evd
packages are automatically available for truncation.")
(license license:gpl2+)))
+(define-public r-trycatchlog
+ (package
+ (name "r-trycatchlog")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tryCatchLog" version))
+ (sha256
+ (base32 "0k40a48qzwmardjnkf0h5s5zryivzvdanz61kxdqdfqlil19ma0d"))))
+ (properties `((upstream-name . "tryCatchLog")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/aryoda/tryCatchLog")
+ (synopsis "Advanced tryCatch and try functions")
+ (description
+ "This package provides advanced @code{tryCatch} and @code{try} functions
+for better error handling (logging, stack trace with source code references
+and support for post-mortem analysis via dump files).")
+ (license license:gpl3)))
+
(define-public r-rsolnp
(package
(name "r-rsolnp")